nproos
Bronze

Re: Dell XPS 13 typing special characters with keyboard

The default Bios and/or keyboard driver (not sure) allows the typing of "special characters" eg when you press "Right Alt" + "2" you get m² instead of m2 or pressing "Right Shift" +"6" followed by e types ê instead of ^e. There are various other combinations. This function could however be turned on or off and it seems to be off by default. When cleaning my keyboard I managed to switch it on by accident (since the original post). It would however be nice to know how this function is turned on and off and possibly get a list of combinations (I have managed to figure out a few)

0 Kudos
nproos
Bronze

Re: Dell XPS 13 typing special characters with keyboard

Apologies, it should be the "Right Alt" and "Right Shift". I corrected the original post

0 Kudos
nproos
Bronze

Re: Dell XPS 13 typing special characters with keyboard

FOUND IT!!! Press "Fn + Ctrl + LShift" simultaneously to activate and deactivate special character typing

FritzJoen
Copper

RE: Dell XPS 13 typing special characters with keyboard

To enter rare characters use either the Alt-numeric-keyboard entry like Alt129 (does not work on all keyboards) or Alt0252 for ü or – in Word – real Unicode. In Word type for example 00FC, mark that, type AltC (for "code") and you’ll see the ü. AltC works both ways, for the most exotic characters! Very useful if you have no real numeric pad, but alas only in Word. You can also build your own custom keyboard with Microsoft Keyboard Layout Creator at http://www.microsoft.com/en-us/download/details.aspx?id=22339. I decscribe the usage – alas in German – at http://blogabissl.blogspot.com/2013/09/tastaturtreiber-andern-ab-windows-vista.html. <Admin Note:email address removed per privacy policy~RK>  More, but not all working at http://www.fileformat.info/tip/microsoft/enter_unicode.htm

0 Kudos
Rachie3.14
Copper

RE: Dell XPS 13 typing special characters with keyboard

Try this: Pull up the on-screen keyboard. you can find it with search on the start menu. On the keyboard go to "options," then check the the box that says "turn on numeric keyboard." Viola! You have to press alt on the normal key board while you click on numbers in the number pad on the on-screen keyboard.

Tags (1)
0 Kudos
Amit Mane
Copper

RE: Dell XPS 13 typing special characters with keyboard

Thank you it works.

0 Kudos
dnl87
Copper

RE: Dell XPS 13 typing special characters with keyboard

Where is this option, I can't find it.

I need to type italian capital accented letters. Thanks

0 Kudos
dareys
Copper

RE: Dell XPS 13 typing special characters with keyboard

Greetings, 

Apparently, you have to enable/disable special character generation using the following sequence?

 "Fn + Ctrl + LShift"

Please confirm. If true what key sequence would you have to enter to create "ê"?

Normally, it would be "ALT-138" ...

Please advise.

Regards,

Jean-Pierre

0 Kudos
Markles
Copper

RE: Dell XPS 13 typing special characters with keyboard

Thank you for this comment. I am in the same boat. I will be selling a 6-month-old XPS and buying a new laptop. This is inexcusable on Dell's part.

0 Kudos
Markles
Copper

RE: Dell XPS 13 typing special characters with keyboard

This does not work on a Dell XPS 13 9360. I was told today be Dell support that I would need to use an external keyboard or use the Win Char Map. Epic fail on Dell's part.

0 Kudos