Highlighted

Driver Error- Device Object Not Present

I have a Inspiron 6000 I was listening to a podcast using Itunes when the sound just stopped working, (this happened a year ago and I just reinstalled the driver and it fixed the problem) now when I tried reinstalling the driver R99254 and I get an error message saying Device Object Not Present, restart the system and run setup again. Does anyone know how to fix the problem? When I go the device setup it does not have the driver listed there.

 

Thanks!

Message Edited by TheEvilPeter on 03-31-2008 06:24 AM
0 Kudos
6 Replies
saurabh57
Copper

Re: Driver Error- Device Object Not Present

Hi

I am also getting the same problem, if you have got the solution, please let me know.

 

Thanks,

Saurabh

0 Kudos
Jim Coates
Diamond

Re: Driver Error- Device Object Not Present

This is usually due to either a failure of the audio chip, or a need to install the chipset driver.

 

1.  Try running the audio test in Dell Diagnostics. This interactive audio test is designed to narrow down the problem to either the software or hardware. To run Diagnostics restart the computer and as soon as it starts to boot up hold down f12. Select 'Diagnostic' from the boot menu. The computer will run its pre-boot assessment tests (PSA) before the Dell Diagnostic starts. The PSA tests play some beeps and tones through the system speaker but this doesn't test the rest of the audio hardware, so you still need to let Dell Diagnostics run after the PSA. Dell Diagnostics plays an instrumental piece of music complete with drums, so if you only hear some tones then you have only run the PSA.

When Dell Diagnostics opens, select 'custom', then the audio test. This will test your audio system independently of Windows and drivers, meaning it doesn't matter if they are working correctly or not. Alternate between using headphones and listening to speakers in case only one is working.

[If you have ever reformatted your hard drive then the Diagnostics partition might have been wiped off. If the Dell Diagnostics option fails to open, run it from the Drivers and Utilities (Resource) CD if you have one.]

Dell Diagnostics will play some audio and ask you whether you heard it. If you answer 'no' then the test generates an error code that means you indicated you did not hear the sounds it played, but it doesn't and cannot pinpoint the exact component that has gone bad. If you don't hear the music during the test it definitely means there is a hardware failure somewhere in the system. In this case Dell will repair the computer if it is still under warranty.

If you do hear the audio that almost always means the hardware is okay but there is a problem with the software or configuration.

 

2. These instructions are for a situation where an operating system has already been reinstalled and everything works except the audio driver will not install ... usually you get an error message, because the NSS and chipset drivers were not installed correctly and the audio chip on the motherboard is not recognized. In this situation "usually" a fresh install of the OS is not required, just re-installing the NSS and chipset correctly. If that doesn't work then a full reinstallation may be necessary.

After you have performed an Operating System re-installation, install the audio driver following this order of installation:

a. Install Dell Notebook System Software (on your downloads page expand the System Utilities category). Restart.

b. Next install the Intel Mobile Chipset driver (expand the Chipset category). Restart.
(Models with AMD cpu use the AMD processor driver.)

c. Install the Sigmatel or IDT audio driver (expand the Audio category).

Get these from the driver downloads page. When you get on the page use the dropdown box to select your Operating System.

Jim Coates -- 14 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos
me_Whynot11
Copper

Re: Driver Error- Device Object Not Present

I have a similar problem and it is driving me nuts ...

The laptop was working fine until I did the family laptop shuffle.  The eldest daughter got my XPS and my wife got the daughter’s Inspiron 6000.  To remove all the accumulated detritus (that only a teenager would put on their laptop) I reformatted the Inspiron 6000. 

First, I installed a slipstreamed version of XP Professional with SP3.  Then I installed the drivers from the Dell install disk.  All the drivers except the sound driver installed OK.  The sound card driver gave the dreaded “Device Object Not Present” error message.  I poked around on the forums and tried installing kb888111.exe and kb835221.exe.  No luck.

Then I came across this article.  The Dell diagnostic disk indicates that the sound card works OK (I got eight tones).  I retried installing the drivers, in the suggested sequence, using the Dell Drivers and my Service Tag.  Still no luck.

Thinking that it may have something to do with the slipstreamed version of XP SP3, I reformatted and reinstalled XP (no service pack).  The driver install routine would refuse to work (required SP1).  Then applied SP1 and tried again.  The sound driver would still not install.

I have given up.  I reinstalled XP using my slipstreamed SP3.  The sound card still does not work, but the speakers make a healthy beep when the install fails.

Any ideas?      

0 Kudos
Jim Coates
Diamond

Re: Driver Error- Device Object Not Present

I think kb888111.exe  just pertains to systems with HD audio. The 6000 has the earlier AC97 protocol.

 

The 8 tones were probably the system tones generated by the PSA test. I would go ahead and run the audio test in Dell Diagnostics. If the option to run audio isn't there in Diagnostics under 'Custom', that is a sign of a dead audio chip.

 

I don't know why but there seems to be more than normal problems installing on a 6000. If the Diagnostics passes, try removing the modem physically from the computer. A failing modem will interfere with the audio installation. Maybe try an earlier or later version of the driver.

 

The first Sigmatel driver linked to on the 6000 downloads page (in the Audio category) will be the current one, R99254 (5.10.0.4255). If you click on it and go to its page, you will see an "other versions" link that will link to an earlier version.

Jim Coates -- 14 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos
me_Whynot11
Copper

Re: Driver Error- Device Object Not Present

I removed the modem, tried to reinstall the sound drivers, no success.

I have already tried three different sound card drivers; one off the installation CD and the two available on the Dell web site.  No Success.

For the moment, I think we can park the hypothesis that the sound card has physically died.  Because: A) It was working fine until I did the reformat, and B); running the sound test (by booting off the Dell Resources CD and running the Dell diagnostics) indicates the audio passes test.

(scratch head...)     

0 Kudos
me_Whynot11
Copper

Re: Driver Error- Device Object Not Present

An update to close off this problem.  I fixed it by apply hotfix KB835221.exe.  Worked perfectly from then on.  Don't download a copy from the Microsoft web site, it appears to redirect users to kb888111. 

 

 

 

 

Tags (1)
0 Kudos