Highlighted

Latitude E5470 TPM Disappeared from Device Manager

Jump to solution

At my employer we have experienced several issues with the TPM disappearing from device manager.

This causes us to not be able to reactivate bit-locker.

We would image the device with Windows 7 Enterprise.

We have had this happen with several machines that did and did not have windows updates processed.

Same with Dell drivers and BIOS processed and not processed.

I have run HWINFO tool and it lists the TPM with a memory address of something like 0000FED4000 yet I cannot find that in device manager or msinfo32.

I have went in to the BIOS and turned off the TPM and turned it back on and activated it.

I have reloaded the BIOS firmware.

If we re-image the laptops the TPM shows up in the device manager as expected so I do not believe this to be a problem with the motherboard.

Oddly enough though we have had motherboards replaced and the TPM shows up.

I don't feel that replacing the motherboard is the solution to this issue as we can restore functionality with a re-image or reload of the OS from scratch. But that doesn't satisfy the risk of the issue rearing its head again.

I have searched for weeks to find a solution to this problem but I have come up short.

I am certain others are having this issue.

With all the drivers processed and windows updates processed it does not resolve the issue.

What do you think I am missing?

I thank you for taking the time to review this.

-Jason

Tags (2)
0 Kudos
3 Replies

RE: Latitude E5470 TPM Disappeared from Device Manager

Jump to solution

BELOW IS THE SOLUTION

Power off the laptop and remove any power adapters.

Remove the rear cover (screws do not come out fully).

Remove the SODIMM(s).

Remove the battery (one screw, pull the tab to remove the battery connector from the board).

Press and hold the power button for 20 seconds (to drain capacitors).

Reinstall the SODIMM(s).

Reconnect the battery and screw it down.

Attach the rear cover.

Power on the laptop, boot into windows, open Device Manager and verify the TPM is listed under Security Devices.

holycow90
Copper

RE: Latitude E5470 TPM Disappeared from Device Manager

Jump to solution

Worked at first, but then back to missing.

0 Kudos

RE: Latitude E5470 TPM Disappeared from Device Manager

Jump to solution

I don't know specifically what is  wrong and why it keeps disappearing, but with the solution I provided I am lead to believe it is an issue with the capacitors.

I would suggest contacting support and telling them of your findings. They may replace the motherboard.

0 Kudos