yahyaskh
Copper

Vostro 1500, Corrupted display

Hi everyone,

I have this Dell vostro 1500 since 2years and half ago ...

Yesterday after trying to connect my Vostro 1500 to TV via S-Video port the display became corrupted. I turned off my laptop, disconnected it from AC adaptor and removed the battery. Then I pressed the POWER button to discharge any potential electricity. Then after a few minutes I turned it on and the problem was still remaining. I tried to fix it by uninstalling and re-installing the Drivers but it didn't help. I restored my computer using Dell Recovery and it didn't help either.

Symptoms:

When the computer starts to boot everything is normal till windows logon screen. the Background is OK in welcome screen but the "Account Picture" is corrupted. When I logon to windows everything is some kinda "checked". Here it is the screenshot that I took after loging on to windows.

 

The strange thing is When I Disable the "NVIDIA GEFORCE 8600M GT" (which is my graphic adaptor) everything goes normal and the display is not corrupted anymore. But, it uses "Standard VGA adaptor" and it has not the desired performance. Does the computer uses an On-Board chip to display graphics in this mode? Why the screen is artifact-free in this mode?

Does anyone have any Idea about how to fix this problem ?

Thank you everybody

0 Kudos
4 Replies
ejn63
Diamond

Re: Vostro 1500, Corrupted display

Replace the video card.

 

0 Kudos
Highlighted
Moderator
Moderator

Re: Vostro 1500, Corrupted display

Hi,

It looks like you graphics driver is corrupted, kindly follow this link to update your video card driver, http://www.nvidia.com/Download/index5.aspx?lang=en-us , select your card type, and the operating system, and download the driver and run it on the computer.

 

Thank you

Royan

Moderator
Moderator

Re: Vostro 1500, Corrupted display

You can also download it from our Dell support site, click on the link and then click on download follow the onscreen instructions. http://support.dell.com/support/downloads/format.aspx?c=us&cs=2684&l=en&s=pub&deviceid=13668&libid=6...

 

Thank you

Royan

ejn63
Diamond

Re: Vostro 1500, Corrupted display

If the card works with standard VGA drivers, but not with the nVidia drivers, it's the chip that has failed - the 8600GT is one of those known to be of faulty engineering (though there never was an admission on nVidia's part that the ones used in this model were faulty, so there was no warranty extension to cover it).

This is the card you'll need to replace the faulty one:

http://www.parts-people.com/index.php?action=item&id=6032

 

0 Kudos