Highlighted
berolinux
1 Copper

XPS13 9343 -- BIOS Bugs, HDMI/VGA am Dock funktioniert nicht

Grüezi,

habe gerade meinen XPS13 9343 (Developer Edition) erhalten. Insgesamt ein gutes Gerät, aber das BIOS (auch nach dem A04-Update) ist etwas buggy: Wenn in der EFI System Partition keine Datei namens EFI\BOOT\BOOTX64.EFI existiert, wird das SSD nicht als bootfähig erkannt, auch wenn EFI\openmandriva\grubx64.efi existiert und die Konfiguration dazu in efibootmgr richtig aussieht.

Auch grubx64.efi im BIOS-Setup von Hand auswählen bootet nicht.

Ein einfaches "mkdir /boot/efi/EFI/BOOT ; cp /boot/efi/EFI/openmandriva/grubx64.efi /boot/efi/EFI/BOOT/BOOTX64.EFI" hilft -- sollte aber eigentlich nicht nötig sein und wird weniger erfahrene User zum Verzweifeln bringen.

Wir haben einen entsprechenden Workaround in den OpenMandriva-Installer eingebaut, aber ein BIOS, das den UEFI-Specs folgt wäre eine schönere Lösung.

Ausserdem funktionieren die HDMI und VGA-Anschlüsse an dem USB 3.0-Dock nicht - wie sich herausstellt, wird ein DisplayLink-Chipsatz verwendet, für den es noch keinen Linux-Treiber gibt. (Und das Dock wurde als "empfohlenes Zubehör" für den XPS13 mit vorinstalliertem Linux angeboten...)

Ist hier bald mit Abhilfe zu rechnen, oder soll ich das unbrauchbare Dock zurückschicken?

1 ANTWORT 1
Community Manager
Community Manager

RE: XPS13 9343 -- BIOS Bugs, HDMI/VGA am Dock funktioniert nicht

Hallo,

Wir hatten auch schon bei den Vorgänger Developer Editions keine konkrete Lösung. Gib die Dock bitte zurück.

Grüße

Tom



DellTom Guenther
Community Technologist - Business Client
Social Media and Communities Professional
Twitter | LinkedIn | XING