Last reply by 09-28-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

5290 2-in-1 Network boot with Dock


I have a Dell 5290 2-in-1 tablet I need to rebuild with our company image. Originally just the tablet arrived so a dock and other accessories were ordered.

My question is can the tablet be network booted using either PXE/UEFI via the dock, as there is no link or activity LED action, or can this only be done via a USB RJ45 adapter?

Many thanks

Jim Layland

Replies (4)
2 Bronze
2 Bronze

same issue here. I tried with the DisplayLink D6000 dock and a LAN7500 Usb to Ethernet adapter.

No luck so far. I'll post if i have a solution...



I called the Dell support line to try and establish how to network boot. Unfortunately, after being passed around several times the guy I ended up speaking to had not got a clue what network booting was and I ended up just putting the phone. Only had to call Dell Support a few times and really not very impressed.

Basically the D6000 dock does work with the 5290 2-in1 tablet, however, you need to be in Windows and install/update the drivers for it and voila, a working dock. Unfortunately, this still doesn't help with networking booting so I have had to resort in wasting a lot more time in manually building it and should it ever need rebuilding, it will need to be factory reset and set up manually again.

I can only assume, as like the Microsoft Surface, there may be a USB to RJ45 dongle that will allow network booting from PXE/UEFI.

Very disappointed Dell support could not give me this information.

2 Bronze
2 Bronze

I know I'm necroing a nearly 4 year old thread, but since it hits so high on the results list, I thought I'd let y'all know "the fix."


I Have the dell DA-300 USB-C mini dock, and I went in to enable the PXE boot by setting the following:

Advanced Boot Uptions - Enable UEFI Network Stack (legacy/attempt unchecked)

System Configuration: Thunderbolt Adapter Configuration:  Check all three boxes (Enable Thunderbolt, Preboot, adapter boot)

The security level only influences if you have to authorize the dock, i use user authorization.


Turning on these 4 settings allowed my to boot from the DA-300 mini dock to my PXE/SCCM/WDS server.


2 Bronze
2 Bronze

I was able to resolve the problem by using a Thunderbolt WD-19 Dock. Dell also sells USB-C adapters to that state they allow you to PXE boot on these tablets; which I've used in the past successfully, but have since misplaced. 

It took me a while to figure it out, I tried using a Belkin brand USB-C adapter, regular USB NIC and D6000 dock, nothing worked at first until I used the Thunderbolt WD-19 dock. 


Latest Solutions
Top Contributor