Highlighted
2 Bronze

5290 2-in-1 hanging at Dell screen when connected to WD-15 dock with new BIOS

I've updated all of our 5290 2-in1s to BIOS v1.9.0 and now when they are connect to the WD-15 dock the systems will hang at the Dell logo unless the travel keyboard is in the down position.  Is there a BIOS option that I need to select to stop this from happening.  The docks are all updated with the newest firmware.

Labels (2)
5 Replies
Highlighted
1 Copper

Re: 5290 2-in-1 hanging at Dell screen when connected to WD-15 dock with new BIOS

I have the same problem with several 5290 2-in-1s that are currently being installed w/multiple monitors attached.  If you disconnect the usb-c cable the boot continues or if you reboot with the 5290 2-in-1 in the open position.  

I have updated the firmware, chipset, video drivers etc..  no luck.  The only thing that seems to fix it is to call Dell and have the motherboard replaced.  

0 Kudos
Highlighted
2 Bronze

Re: 5290 2-in-1 hanging at Dell screen when connected to WD-15 dock with new BIOS

Try the 1.10.0 BIOS.  It seems to have fixed the issue for us.

0 Kudos
Highlighted
1 Copper

Re: 5290 2-in-1 hanging at Dell screen when connected to WD-15 dock with new BIOS

I have the same issue.

Setup:

5290 plugged into WD15.

2 monitors plugged into WD15.

After update to latest bios, 1.10.0, when powering up by pressing the small power button on 5290, the system hangs at the Dell screen, the circular moving ring is not visible.

What works for me is, I press the power button to turn it off.  Then when I press the button again, it boots fine.

So it seems after bios update, it boots up fine on the second power application.

Any thoughts?  I read somewhere it's about the legacy boot setting.

0 Kudos
Highlighted
1 Copper

Re: 5290 2-in-1 hanging at Dell screen when connected to WD-15 dock with new BIOS

So Dell swooped in and PM'd as I had warranty coverage.  After I did a BIOS update the problem went away.  All working fine now.  Just wanted to leave a trail for anyone that has this problem in the future.

0 Kudos
Highlighted
2 Bronze

Re: 5290 2-in-1 hanging at Dell screen when connected to WD-15 dock with new BIOS

We finally abandoned the WD15s for the WD19s. They work much better with multiple monitors.  All of our Dell systems that use the docks are set to UEFI boot. 

0 Kudos