Highlighted
iPatrickH
1 Nickel

BIOS flash will not Upgrade nor Downgrade,stuck at A09

Dell Latitude (7404) -  I am suspecting the last bios update I performed A09 corrupted the chip to a usable but semi-unstable system exerting behavior un-correctable when downgrade/upgrading the BIOS versions. Answers and reply's need to be Out of the box thinking. All basic and advanced steps were performed. bring your Jedi nightforce mode on.  

Issue: 
BIOS flash will not Upgrade nor Downgrade its current version Stuck at A09

Symptoms:

  • 99% of the time cannot add UEFI boot path manually.
  • F12, UEFI boot partitions options not present,  not displaying.
  • Switching from UEFI Secured boot back to Legacy back to UEFI unsecured "by Luck" bring back UEFI  boot partition
  • trying to boot from usb is difficult, trying the above step "by luck" sometimes work
  • When switching from UEFI to Legacy, boot sequence/priority does not show
  • load bios defaults/reboot system built in display does not turn on (fn+power diagnostics revives laptop)
  • 1% of the time unable to make system BIOS changes all ticks grayed out after loadting defaults
  • 1% of the time and only once I have seen legacy display all normal boot options. It is possible. does it work? is the question.   
  • BIOS does boot slower however this could be because of the default "through" setting.
  • Diagnostics pass
  • Windows BIOS flash, restarts, Black screen, Dell BIOS logo, Boots back to windows = BIOS version unchanged
  • F12 BIOS flash restarts, Black screen, Dell BIOS logo, Boots to selected boot path UEFI

Remedy steps tried:

  • Windows BIOS update
  • USB Legacy DOS <not able to boot legacy options not available> 
  • F12 BIOS Flash
  • unplug AC/DC power converter, removed battery, removed cmos battery, removed ram, power button for 30sec, insert 1 ram stick, plug in AC/DC power converter, power button = No display, power button turn off.
    fn+power button Boots to Diagnostics, after 10 minuets Display comes back. 
     

What hasn't been tried

  • Bin File and Linux <- (does not exist). 
  • UEFI DOS mode <- (if this is even possible, because DOS is legacy)
  • PXe boot and install Dos to hard drive 
  • COM1 RS232 port reprogramming, 7404 has these ports. 
  • BIOS chip extraction - reinsertion
  • test clip and BIOS reprogramming jtag
Labels (6)
0 Kudos
2 Replies
nyc10036
3 Zinc

Re: BIOS flash will not Upgrade nor Downgrade,stuck at A09

Try updating the BIOS using a USB stick with FreeDOS image ( http://joelinoff.com/blog/?p=431 )  and the EXE file.  I used it to downgrade BIOS on E6400.

Create the bootable USB flash drive.

F12 to change boot order to boot from the USB flash drive. You will end up in DOS.

Run  ****.EXE file

 

.

 

 

0 Kudos
iPatrickH
1 Nickel

Re: BIOS flash will not Upgrade nor Downgrade,stuck at A09

D335E4ED-3648-46BC-9CB9-BDD96EF34869.jpeg

 

FA064C52-5E55-4E30-A210-374562752385.jpeg

 

9762B390-D024-4D27-90ED-8A8738CD3A0A.jpeg

 

4EB84DBD-DCC5-4EF7-AFEA-9ADFC1D644FF.png

 

895ACA4B-D399-4D73-A02E-FFCF183F23EA.png

 

D1A16249-AB18-47D1-82C7-65E865A0D7B4.png

 

B498DEEA-675E-4447-B82C-4FBB370ED914.png

 Thank you for the answer however I do not think you understand the climate of the issue. I have already thought of using Legacy Dos however the bios refuses to set boot priorities and sequence when selecting legacy.

Outside the box thinking is it possible to boot to freedos through integrated NiC w/pxe (pxe-boot)

 

 

0 Kudos