olc123
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

I have a 7440 here with same problem. cpu stuck @0,78GHz. Battery removal does not help. Another battery does not help. Another charger does no help. Downloaded all bioses available, installed them all from A01, nothing happens. Only throttle stop can get it running @Speed again. Havent seen any battery or charger warnings nor errors. Any hope to get it running without throttlestop?
0 Kudos
raf2222
2 Iron

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

You should try to install the software "Dell Power Manager".

In the "Thermal Management" tab, you need to select option "Optimized".

-----

Your issue might be that you computer is currently locked in the mode "Quiet" or "Cool" which can cause your CPU to be limited at 0.8GHz

0 Kudos
Pjotr77
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

For me the solution was to remove the screw below the c-key, as suggested by a few people in the comments to this post (with youtube video): http://triplescomputers.com/blog/casestudies/solution-cpu-throttling-on-dell-latitude-ultrabooks-e74... As an indication: I noted that the core speed would shortly increase after hitting the bottom of the laptop on the left side (i.e. in the area below the c-key).

reeyon
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

Hello there,

Thanks for the good guide, it really save my days.....
I have been troubleshooting for 5 days, until I saw this post. 

I removed the screw underneath the keyboard, and then the CPU throttling is gone.

I'm happy!

Dragoic
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

Worked perfectly. I work in a company with over 500 Dell E7440 and as the years went by did this issues start to show up and we contacted Dell. No one could give a good explanation to why some of our E7440 out of the blue started to act up and even send a service guy. He did the debugging and diagnostic and no of them gave error or reported an issue. So they concluded it was a defect motherboard or CPU. Unlucky for us had the warranty already ran out and and buying parts costed the same as a new laptop.

After long time looking did i finally came across this answer and a youtube video and i was a little.. Yeah..you are pulling my leg right? and i tried it and boom the CPU went up to 100% and the right clock speed like nothing was wrong.

I did notice a minor details, that was the crashes that happened afterwards. I think i solved the issue by putting a piece of tape underneath the metal plate and the motherboard. So the plate where the keyboard is attached to can't touch they motherboard.

0 Kudos
Sadith
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

tengo un DELL LATITUDE E7440 con procesador Intel core i5 – 4310U, 8Gb de RAM y ssd de 250 GB.

he probado retirar la bateria y encenderla solo con el adaptador AC y arranco super bien, rondando los 2,9Ghz, pero luego de un minuto volvio a estancarse en 0,78GHz. Cuando presiono la parte inferior del portatil, debajo de la letra c, la frecuenci vuelve a aumentar, intentare retirar el tornillo

0 Kudos
ITM Computers
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

Hi there,

 

Go to BIOS, by pressing F2 on start up , than go to Performance, and click on +. Find Option Intel SpeedStep TM, and Disable it.

By this operation CPU will be working on highest performance. However this will for sure decrease the battery state, but will solve the issue with CPU itself.

No need for removing the screw underneath C letter, or other removal interventions. 

Problem should be investigated deeper.

0 Kudos
PowderGeek
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

NOPE...I've turned off Speedstep on other Dell's and it fixed the slowness issue, But not on this 7440. BIOS A28.

ThrottleStop WILL turn it on full speed, but that's a pain as it needs to be run every time.

 

REMOVING THE SCREW under the 'C' key worked for me, too.

You'll need  Phillips (P) and fine-tipped Flathead (F) screwdrivers or one of those Apple iphone tools - Spudger (S).

  • Shut down
  • Unplug from power
  • Remove the battery
  • Remove the 2 P screws that hold the back cover in place that are in the battery compartment's upper left and right corners
  • Remove the  2 P screws that have the K near them (they hold down the keyboard)
  • Flip over the laptop
  • CAREFULLY Pry up and Remove the trim piece around the keyboard with F or S tool - the part that has 'LATITUDE E7440' printed on it
  • Remove the 3  silver-colored metal P screws along the top of the keyboard that are now exposed
  • Carefully lift up the keyboard until the P screw under the 'C' key area is accessible
  • Remove the P screw
  • Reinstall everything in reverse order

POWA RESTORED.

 

LoggerSam
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

I also confirm that removing the P screen under the C key worked!

I have a 5+ year old latitude E7440 that was stuck at 0.78 GHz.   I first tried to reset the BIOS by unplugging and replugging the CMOS battery.    That didn’t work.   (btw - that initially caused my computer to brick.  (Solved thanks to https://www.dell.com/community/Latitude/Dell-Latitude-E7440-won-t-boot/m-p/7352541/highlight/true#M1...)


 I followed instructions from @PowderGeek and that fixed the issue.

at first my keyboard didn’t work upon reassembly.   I found that the connecting cables became unplugged while I removed and reinstalled the keyboard. They’re funky flat ribbons that snap into a connector.    I learned how to reconnect keyboard cables by consulting pics here:   Look at KeyBoard section of this link
https://www.dell.com/support/article/en-us/sln288313/dell-latitude-e7440-customer-replaceable-unit-c...

Now my computer is fully restored!   Happy Days 🙂

Thanks to all for sharing your discoveries!

jcheung22
2 Bronze

Re: CPU Core Speed stuck at 0.80GHz Latitude e7440

Yes, I confirm the screw remove fix works. My reaction was <Profanity removed>?!?

I have 2 questions :

1. Who/how did this fix get discovered?

2. What is the screw used for?

0 Kudos