Start a Discussion
2 Bronze
2 Bronze

DCU version 4.1.0 unable to retrieve system inventory information on Latitude E6230

I'm running Win 10 Pro, 64-bit OS on my Latitude E6230 and lately the Dell Command Update will not complete and displays: "unable to retrieve system inventory information." I've uninstalled & re-installed both Dell-Command-Update-Application-for-Windows-10_DF2DT_WIN_4.1.0_A00 and Dell-Command-Update-Application_P5R35_WIN_4.1.0_A00 execution files with no luck. Any suggestions please?

Replies (95)
2 Bronze
2 Bronze

I'm having the exact same problem with a Latitude E5430 and DCU 4.1.0.  "Unable to retrieve system inventory information." and System Information says "A problem occurred while checking to see if the operation has completed."  Just completely reinstalled Windows, thinking it was just something corrupted, but still have the issue.    Maybe something in the BIOS?

2 Bronze
2 Bronze

I am also seeing exactly the same issue, started in the last week.

The only odd thing I have seen an older device I installed this on did work and connected showing required drivers. It had been off the network for more than 6 months.  So has many Windows updates missing at present.

New built devices also have this issue.

So very strange.

 So I've been using DCU since I believe Ver 3.1.2 exclusively from all my dell driver updates. Been upgrading over the time when it becomes available (3.1.3 > 4.0 > 4.1) without issue. I've been using the 4.1 for at least 3-4 weeks now I believe, without issue. Then suddenly within the past week error "unable to retrieve system inventory information" on any device that's running 4.1. OK, weird, but whatever probably just a hiccup on Dell's delivery system. Tried again yesterday, same error. Occurs on Precision 3420, 3430, 3440 & 3441 models. Hooked up to my HotSpot to rule out internal firewall systems, etc. w/ no change. So onward to Google to where I finally found this thread.

  I tried the couple t/s steps here by going back to 4.0 w/ no change. Then to 3.1.3 with finally a result of "No Updates Found". Seems kind of odd, figured it should at least find the 4.1 update.

 Through all this, to me it sounds like something is happening on Dell's side that is not specific to the actual application itself. Whatever it may be, it clearly is starting to be noticed by others.

So here's some updates:

I rebuilt a Precision 3430 w/ 1909 (yes I know, it's older) and loaded the Win32/64Bit for Win7/8/8.1 and 10 Version of DCU which is still Ver 4.1. Installed without issue, etc. App launched and found updates, no errors. I normally use the Universal Windows Platform Ver which is still 4.1 and never had a problem with it until the past week. Maybe they've fixed their issues, so I check my workstation, nope same problem. I removed the universal windows version that I always use, reboot & install the Win7-10 Build. It still failed with the error that everyone is receiving related to this thread topic.....???

Ok, so I rebuilt a different Precision 3430 same setup as above. Works like a charm with finding updates and applying. So why can't my workstation work? Why does a rebuild seem to work. I know it's a small use case scenario, but something is definitely wrong on Dells side.

Same here as of today, 4/8/21.

This is after DCU update on 4/3/21.  <Service Tag removed>

While we also are using McAfee ENS 10.7 as BAC1984 was discussing, I'm guessing not everyone is?

If we're blaming A/V, then Trend is doing it too.

We have many Windows 10 Dells of all shapes & sizes.

Command Update tanks on all of them now.

I'd seen one mention of Windows Defender and swagnerjj had mentioned uninstalling AV- "then DCU runs fine, clearly this isn't a solution."  This was back in mid-March.  Also said "6 agents and 90 minutes later im told that they cant help me and cant tell me what directories / services need to be allowed."  If their application is mimicking a threat they need to fix it.

Top Contributor
Latest Solutions