Highlighted
1 Copper

DW5811e Configuring Mobile Broadband Device Failed error 82

Hi,

I've installed a Mobile Broadband card in my Latitude 7490. When the mobile broadband auto configure hits 37% it fails with error 82. The windows auto config keeps running after a few minutes. This happens after the driver is installed manually.

When I run the automatic driver update from device manager, windows can't find any drivers.

I've downloaded the drivers manually from dell (DW5811e-Qualcomm-Snapdragon-X7-LTE). After installing the driver, I can't find the mobile broardband in device manager, and it seems like device manager keeps refreshing. Sometimes it when refreshing the mobilebroadband shows up in "Other devices" and then it disapeas again.

I've deleted, reinstalled and re-downloaded the driver a few times

 

4 Replies
Highlighted
1 Copper

Re: DW5811e Configuring Mobile Broadband Device Failed error 82

I have the same error. It seems it is trying to update the card firmware but it fails.
Highlighted
2 Bronze

Re: DW5811e Configuring Mobile Broadband Device Failed error 82

DW5811e-Qualcomm-Snapdragon-X7-LTE-Firmware-and-GNSS_97FX1_WIN_7.54.4799.502_A06.EXE for unknown do not provide drivers for some modules of LTE modem.  The issue was solved in a way to export all drivers from pre-installed OS Win10 Pro PowerShell run as admin Export-WindowsDriver -Online -Destination C:\Users\driverbackup Windows Device Manager automatically search for a driver in the exported folder by right-clicking the device, going to "Update driver" and following the prompts for "Manually install a driver" until you can browse to your drivers. This procedure was done for 3 devices that were not recognized. After that, the firmware update with the standard software was successful.
0 Kudos
Highlighted
1 Copper

Re: DW5811e Configuring Mobile Broadband Device Failed error 82

Hi, I also have this issue for DW5816e. Could you be more specific about "Manually install a driver"? I assume manually updating drivers is the same as let windows find best from pre-installed OS drivers.

Thanks.

0 Kudos
Highlighted
1 Copper

Re: DW5811e Configuring Mobile Broadband Device Failed error 82

If its not too late... or the next one with this problems.

 

I ran the install several times and allways get the same Error 82 after it.

 

Just let the system work. After a while and many errors 82 it'll finish (in my case at least - Dell 5490 )

 

My next Problem was that it told me that its connected but "no internet available".


The solution for me was in the APN Settings in the Advanced Settings.

First it was @Automatic. After choosing the (in Germany for me Telekom APN) it worked BUT changed directly back to Automatic .... Hmmmm... Never mind it worked. I tried it immediately again and it disconnected and connected again.

Hope that'll help other one with the same problem.

0 Kudos