Highlighted
KingCornWallis
1 Nickel

Dell Studio 1569 CPU Upgrade Unsuccessful

I recently attempted an upgrade of my Dell Studio 1569. I picked out an i7 820qm, as well as the board variant with ATI Radeon HD 4570 512MB and a proper heatsink.

As this motherboard is based on the HM57 Chipset, it should work IN THEORY. I have updated the BIOS to A09 (latest)

Upon booting with the new processor I will hear the disc drive and see the power light turn on and stay there. Nothing appears on the screen. I also tried booting holding the D key and the screen will flash to different colors as expected. 

The laptop still works fine with the old i5 450M cpu. I'm aware that the 1st gen quad core CPU's do not have integrated graphics, but I don't know why my computer won't use the ATI Chip here.

I have tried an external display using HDMI and nothing has appeared.

It looks like what I am doing is unprecedented (as this is a very obscure laptop), so I am willing to hear from people who don't have this laptop.

 

Thanks

Tags (4)
0 Kudos