Latitude

Last reply by 01-15-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

Intermittent Ethernet Wired connection Issue in Dell Latitude 7420

In my new Dell laptop, whenever I connect an ethernet cable it will disconnect from the internet for few seconds(5 sec) and reconnect immediately. Wifi connection is ok. It has been checked with different cables but the problem persists and an old laptop works fine with same ethernet cable.

Activities done from my side,

1. Ensured that I'm using a single internet connection i.e a wired (Ethernet LAN cable)
2, Rebooted my home network modem/ router.
3. Disabled IPv6 on my network adapter
4. Checked for any packet loss and could not find anything yet

5. Ensured all network drivers are upto date

Machine Details : Dell Latitude 7420
Operating System: Microsoft Windows 10 x64 Professional

Using Dell  USB 3.1 Type-C to Ethernet Adapter for connecting Ethernet cable(Network Adapter : Realtek USB GbE Family Controller). 

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze

I could resolve the issue by disabling the Realtek USB GbE Family Power Saving mode using Device Manager in the operating system. These are steps I followed,

Open Device Manager -> Navigate to Network Adapters -> Double click on Realtek USB GbE family Controller -> Click the Advanced tab in the menu of the properties window

Scroll down the list under Property: and highlight Idle Power Saving
Click the drop down box under Value: and select Disabled from the list.
Click OK and close the Device Manager window.
Reboot and confirm the issue is resolved.

 

 

View solution in original post

Community Accepted Solution
Replies (21)
2 Bronze
2 Bronze

I could resolve the issue by disabling the Realtek USB GbE Family Power Saving mode using Device Manager in the operating system. These are steps I followed,

Open Device Manager -> Navigate to Network Adapters -> Double click on Realtek USB GbE family Controller -> Click the Advanced tab in the menu of the properties window

Scroll down the list under Property: and highlight Idle Power Saving
Click the drop down box under Value: and select Disabled from the list.
Click OK and close the Device Manager window.
Reboot and confirm the issue is resolved.

 

 

Community Accepted Solution

Thank you for this!  This has been driving us nuts for months.  

For those inclined to automate a fix for this via powershell:  

Set-NetAdapterAdvancedProperty -InterfaceDescription "Realtek USB GbE Family Controller" -DisplayName "Idle Power Saving" -DisplayValue "Disabled"

yes, we also had the same problem. Disable Idle Power Saving helped here. Strangely enough, we only have this with Latitudes (7420/9520). Our Precisions don't do that.

Unfortunately you can only use the PowerShell commando when the dock is plugged in.
If you want to distribute this automatically and it cannot be guaranteed that the dock is plugged in, it will of course not work. does anyone know a way to set the setting for hidden devices?

The problem only arose when doing phone calls with Microsoft Teams. Otherwise we had no problems. We almost got mad too.

Hello,

Using a Dell Latitude 7420 PC with Windows 10 64 bits, this solution helped but the intermittent disconnection from ethernet/wired network when using Ms. Teams still occurred occasionally.

In addition for me it was needed to replace the default driver for “Realtek USB GbE Family Controller” (it was version 10.39.518.2020 from 18 Mai 2020 - for a Dell Latitude 7420 PC bought in October 2021) to fix the issue more permanently. For this I had to use Realtek website directly instead of Dell or Windows update.

https://www.realtek.com > Downloads > Communications Network ICs > PCI GBE name: Realtek PCI GBE Ethernet Family Controller Software > Realtek PCIe FE / GBE / 2.5G / Gaming Ethernet Family Controller Software

Now driver version 10.49.20.1102 from 2 November 2021 is installed, “Idle Power Saving” is still disabled in the Advanced settings,  and the Ethernet connection is stable including with Ms. Teams.

2 Bronze
2 Bronze

Thank you very very much! Fixed it on all our 7420 devices. How is this issue still present in current driver packages??

It still persists with the drivers offered by Dell support page.

But, as sayed. It only occurs when a Teams phone call or meeting is happends.

Aftersome seconds, the network link is getting down. It comes up again, and everything is ok. But it repeats randomly.

 

This also documented here:

Lenovo USB-C Dockingstation and MS Teams Videocall connection lost-English Community

There a also a few links which referes the same problem.

2 Bronze
2 Bronze

In our environment, this will not happen just in combination with teams. As we do not use teams. It just happens randomly due to the day. No matter if we use usb-c ethernet adapter or docking stations like WD15, D1000 or newer displays with embedded dock.

Also we can disable idle mode when device is not plugged in. As the realtek network device is always the same.

2 Bronze
2 Bronze

Same problem here, but the Idle setting is a workaround, not al solution. When working on another docking station the problem returns. We have more then 100 laptops with this issue. Dell, when will there be a permanent solution?

Top Contributor
Latest Solutions