Latitude

Last reply by 10-27-2021 Solved
Start a Discussion
2 Bronze
2 Bronze

LOUD Dell WD19 Dock - Taking off for flight - Please secure all passengers.

Our current corporate builds come with Dell WD19 docking stations. We upgraded to these from WD15's last year.

I had a "VIP" user complain about the noise of his docking station. Initially I thought he must be mistaken and talking about his laptop fans running loud, but no sure enough these WD19 docks come with fans that can move papers off desks, and likely take flight of its own. There is something dead wrong with the firmware on these. 

This particular user is using a Precision 3541, however I have also tested with my Precision 3541 as well as a Latitude 7490. I performed a firmware upgrade:

MicrosoftTeams-image (1).png

 

WD19 Firmware upgrades seem to make zero improvements. I have seen a few other threads longer than 6 pages about this same issue on here, with some back and forth responses but no definite answer. I will NOT be modifying cooling settings and sabotaging performance for a Docking station issue. 

This seems to be a firmware issue, and nothing about ambient temperature or the unit actually trying to cool itself. I brought the dock back to my workbench to record a video of it, which can be located here: https://gofile.io/d/RbOWrw

The reason I suspect this is a firmware issue is that the fan will go from 0 to 100 immediately back to 20 to 100 to 0 to 50 to 0 to 100 in a matter of 15 seconds. This cycle repeats approximately every 5-10 mins.

Curious to know if anyone else is having similar issues.... can't chat with Dell support like I normally do for laptops, and refuse to talk to their phone "customer service" reps

Replies (28)

I had the same problem. Super annoyed as I bought this with my own money to create an additional hotdesk in the house.

Fortunately I used my IT brain to update the firmware.

<ADMIN NOTE: Broken link has been removed from this post by Dell>

To my surprise - it actually worked. (Could be too soon to tell but so far so good).

Stavros

2 Bronze
2 Bronze

Absolutely, the same problem.  My company recommended I just remove the docking station all together and connect directly to my laptop.

Hi, I have had the same issue with my dock. It is very fustrating as it makes me lose focus when I am doing my work.

Same issue here peepS. WD19 is sporadic to say the absolute least, ha.

2 Bronze
2 Bronze

I'm experiencing a similar issue here at Mississippi State University with one of my clients (Latitude 5400 & WD19TB).  It will blow (cold air) at 100% for about 60 seconds, stop (0%) for about 15 seconds, and then go right back to 100% again.  Sometimes when it is blowing, it throttles down to 50% for a second and goes back up to 100%.  Firmware updates have not helped in this case either.  I can provide a video if someone from support wants to see what it does.

Tony Garcia

To keep this up to date I have now managed to get my dock replaced and the replacement, while having the same model number, has not made any fan noise since receiving it. So definitely something weird on some earlier models I guess? Anyhow, my ears are very thankful!

That's exactly it. Thank you! I'm trying to get a better quality recording.

That second video is what you need to be giving to them, thats similar to mine, and is a product issue 100%.

Sure man, here you go: https://gofile.io/d/r9PtCa

Do you still have the video you posted by any chance? I'd like to compare to make sure it is actually as loud and annoying as I think it is. Based on your description it certainly sounds like it.

It's easily the loudest thing in the room compared to a laptop and a gaming pc!

 

Edit: This is what my dock is doing. https://1drv.ms/v/s!AqI7eF-9oukCp_0-1EFWJWIXy4zGXg?e=ZCraFx

And this where the fan goes rapidly 0-100-0-100-0-100: https://1drv.ms/u/s!AqI7eF-9oukCp_1Ad-OHeXNMytA3_Q?e=Gkn2wo

Top Contributor
Latest Solutions