Player1_4eva
1 Copper

Latitude 5289 2-in-1 issues with sleep mode

I've been running the above notebook now for about 9 months or so and this has not been a great experience compared to other Latitudes that I have owned/used.

Issues:

1. Out of the box my Bluetooth failed and had to be replaced.

2. Various quirks around Sleep mode - I have set the notebook to go to sleep when the lid is closed but this is not always the case.

3. When sleep mode goes awry I sometimes open my laptop at my destination and find the keyboard disabled. I have to use the touch keyboard or reboot to get access again.

I had some spare time to have these issues looked at with ProSupport and 2 weeks ago I logged the request, and my mainboard was replaced. On Monday morning I attempted to start my notebook (from sleep mode) and it would not boot with only the keyboard backlight flashing periodically. As soon as I connected the charger the power light on the button came on, but nothing else. I logged another call and my board was replaced again yesterday. It would not boot with the battery connected.

I did some reading this morning and left it to charge for 30 min as requested and low and behold it booted - battery obviously in "Storage mode". 

I've read other threads about severe battery drain in sleep mode on these units - would love to hear others' experiences.

Thanks in advance!

 

 

0 Kudos
1 Reply
Highlighted
Moderator
Moderator

Re: Latitude 5289 2-in-1 issues with sleep mode


@Player1_4eva wrote:

I've been running the above notebook now for about 9 months or so and this has not been a great experience compared to other Latitudes that I have owned/used.

Issues:

1. Out of the box my Bluetooth failed and had to be replaced.

2. Various quirks around Sleep mode - I have set the notebook to go to sleep when the lid is closed but this is not always the case.

3. When sleep mode goes awry I sometimes open my laptop at my destination and find the keyboard disabled. I have to use the touch keyboard or reboot to get access again.

I had some spare time to have these issues looked at with ProSupport and 2 weeks ago I logged the request, and my mainboard was replaced. On Monday morning I attempted to start my notebook (from sleep mode) and it would not boot with only the keyboard backlight flashing periodically. As soon as I connected the charger the power light on the button came on, but nothing else. I logged another call and my board was replaced again yesterday. It would not boot with the battery connected.

I did some reading this morning and left it to charge for 30 min as requested and low and behold it booted - battery obviously in "Storage mode". 

I've read other threads about severe battery drain in sleep mode on these units - would love to hear others' experiences.

Thanks in advance!

 

 


@Player1_4eva thanks for reaching out to the community. I'm sorry to hear of the experiences you have had with the system.

Troubleshooting sleep mode issues can be quite problematic and long winded. The majority of fixes tend to centre around running the latest video and audio drivers and in conjunction with the latest BIOS revision. After than it can be power plan / hibernation settings and configuration related. If the issues are still present at that point, ultimately hardware may be required to fix the issue.

The following article helps in troubleshooting sleep mode problems - https://www.dell.com/support/article/lc/en/lcdhs1/sln122264/troubleshooting-steps-for-computers-that...

You have mentioned that you have recently had some hardware replaced to address the issues. Are you still experiencing the same sleep mode issues after the hardware replacement, or has it only addressed some of the issues?

Has the agent that booked up the service calls for you followed up for the latest updates on the system behaviour?

I'll drop you a private message to get your tag and contact details.

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

0 Kudos