Latitude

Last reply by 11-05-2019 Unsolved
Start a Discussion
2 Bronze
2 Bronze
6348

Latitude 5290 2-in-1 won't charge

Today I noticed that my 5290 2 in 1 won't take charge.

I plug in, and the power LED flashes between amber and white light (1x each taking turn). When I turn it on and plug in while Windows is running, the power status says "plugged in" but also says "not charging." While the windows is running the power LED flashes in the same manner regardless of whether I plug charger in. I have another 3rd party charger that charges this Tablet, but that won't work either.

Did the battery go faulty? I bought this refurbished less than a year ago.

I also wonder if this has to do with the BIOS upgrade, which I did a couple days before this happened.

Replies (9)
5296

Hi,

Bought a used 5290 for around $1000 seeing as they are around $2000-4000 in Australia, I thought it was a killer deal. Went there tested it all, ran all my benchmark testing. Was all A1 btw I am a computer engineer/technician so I do know what to look out for.

Anyways used it for like one day, factory resetted it, went on to updating bios, thunderbolt firmware and the whole works finally kept getting some warnings about the USB-C charging cable was not compatible anymore after these updates.

I think there is something seriuosly wrong with these laptops, or the firmware being pushed out and possibly a bad batch of batteries that may get recalled. These laptops have not even hit the 2 year old mark yet.

Not sure what to do now, buy another dell or just save up more and buy a Lenovo. So devastated I actually really liked this laptop.

 

 

6201

Hi utopik

You can try reseating the battery to check if it helps. If not you can PM us the service tag details we can check the warranty and guide you further.

 

 

Dell-Parnoshree C
Social Media Support
#IWork4Dell
Dell Support Videos
Drivers and Downloads
Driver order

6225

Hi.

No, I haven't tried to disconnect and reinstall the battery if that is what you meant.

My BIOS was at 1.6.0; upgraded to 1.8.0; a few days later battery issue surfaced; downgraded BIOS to 1.6.0; didn't help so tried 1.7.0; didn't help so I upgraded back up to 1.8.0 now.

I'm not sure if the BIOS upgrade is related to this battery issue. I have another friend who also owns the same 5290 2-in-1. I upgraded his BIOS when I did mine. He has no issue yet.

6229

Hi utopik,

Have you tried to reseat the battery and check if it is recognized?

Which version of the BIOS update did you recently installed before this issue occurred?

DELL-Akshatha M
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

6265

1) Yes, the battery installed is Dell battery. Below is the picture I took when I opened the cover last year.

battery.JPG

2) The only hardware change I made was adding 2242 SSD in WWAN slot back in November last year. The battery picture is taken that day, and there had been no issue with anything. 

3) I did the downgrading/upgrading BIOS from BIOS menu. I just moved it back to the newest v. 1.8.0 (this time it went well without any error message), but in BIOS it still shows "Not a Dell Battery." 

BIOS battery status.jpg

One thing that has been bugging me ever since I bought this refurbished Tablet PC is that the battery drains even when PC is completely shut down. Sometimes, I shut it down and don't turn it on for 3-4 days, and when I turn it on next time I notice the battery is all drained. I don't know if that symptom has anything to do with this battery failure (or software failure on battery). A full charge still lasted me 4-5 hours before this happened, so I didn't see this coming.

6282

Hi utopik, 

1) The battery installed in the system, is it a Dell battery?

2) Was there any hardware changes made to this system?

3) Try this step to update BIOS It's best to update BIOS thru BIOS and not thru software. The most usual way is to put updated BIOS file in a USB formatted to Fat32, enter BIOS, choose update and point it to the USB. Once the BIOS is updated restart and check if the problem happens.

4) The error code reported is for Not a Dell battery.

Dell-Parnoshree C
Social Media Support
#IWork4Dell
Dell Support Videos
Drivers and Downloads
Driver order

6298

Thanks for the heads up.

1. F2 >> Battery Information shows that "Health: Not a Dell Battery" and "AC Adapter - 50W" (when plugged in)

2. I updated the BIOS few days ago, so it must be the newest one. I double checked and confirmed. It is v. 1.8.0.

3. AC Adapter LED light (on the usb plug) stays on when I plug in to the Tablet PC (also when not plugged in, as long as the other side is plugged into an outlet). As long as I have the adapter plugged in, the battery level stays at 21%.

4. I went F12 and ran Diagnostics, and again, it is saying the battery is not Dell battery (error code: 2000-0135, validation code: 104650). Under System Health it shows "Primary Battery Health - Permanent Failure).

5. In F12 mode, I reverted the BIOS to the previous version I was on, v. 1.6.0, but that did not solve the issue. I also tried to upgrade to the second latest version, v. 1.7.3, but it didn't help. 

Side note: Every time I flash BIOS, whether downgrading or upgrading, I see "ME Firmware EndUpdate Failed Error: 0x00002236," followed by a message, "ME update failed." BIOS still seemed to be flashed. Despite this error going back to 1.6.0 was "successful" at the end. And when upgrading to 1.7.3, it gave exactly the same error (ME FW update failed) and at the end it said BIOS update was failed, but when I checked the BIOS version in Windows it was upgraded to 1.7.3. What is ME update?

6 Indium
6313

Welcome to the Dell Community  @utopik 

The power LED flashing between amber and white usually means the battery has failed and is unable to charge!!!

It could have been caused by the BIOS update.

Have you tried to roll back the BIOS update???

Checking Battery Health Status on Dell Laptops and Notebooks:

https://www.dell.com/support/article/us/en/04/sln143156/checking-battery-health-status-on-dell-lapto...

Please DO NOT PM these details as others can benefit from your replies.

Best regards,

U2

EDIT: @Dell-Parnoshree C why do you ask an OP to PM details that can benefit others???

3 Argentum
6324

Hi utopik

You can check a few more steps to understand the issue better. 

1. Boot in BIOS restart the system, start tapping F2 when you see the Dell logo. Check the status of battery and ac ac adapter under battery information. 

2. You can check the latest BIOS in the given link https://www.dell.com/support/home/ae/en/aebsdt1/drivers/driversdetails?driverid=ddfd6&oscode=wt64a&p....

3. The light on the ac adapter stays on or goes off when connected to the system? 

PM us these details for further help

Dell-Parnoshree C
Social Media Support
#IWork4Dell
Dell Support Videos
Drivers and Downloads
Driver order

Latest Solutions
Top Contributor