Latitude

Last reply by 12-15-2020 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Latitude 5400 Sleep Crashes in Windows 10 2004

Unfortunately I am also reporting my 4 of 4 my Latitude 5400 are exhibiting poor sleep behaviour and more often than not they are not resuming from sleep cleanly, and may not turn back on, or after some delay will BSOD and reboot. The computer reports entering into connected standby prior to the BSODs.

This is what I am using:

  • Dell factory Windows 1909 image
  • Upgraded to Windows 2004 update
  • Upgraded all drivers and BIOS to current as of June 2020 using Dell Command
  • BIOS v 1.7.4

BSOD Details:

This was probably caused by the following module: pdc.sys (0xFFFFF8041829E5D0)
Bugcheck code: 0x14F (0x4, 0x2, 0xFFFFF8041829E5D0, 0xFFFF9D8FD66E5A50)
Error: PDC_WATCHDOG_TIMEOUT
file path: C:\WINDOWS\system32\drivers\pdc.sys
description: Power Dependency Coordinator Driver
Bug check description: This indicates that a system component failed to respond within the allocated time period, preventing the system from exiting connected standby.
This is likely to be caused by a hardware problem.
The crash took place in a Microsoft module. Your system configuration may be incorrect. Possibly this problem is caused by another driver on your system that cannot be identified at this time.

Notes:

  • Windows 2004 no longer supports Connected Standby alterations via Registry. Its also called Modern Standby now in Microsoft literature... but not in the OS itself.
  • I have removed Sleep modes for users and added Hibernate instead... not too many complaints yet but its early days.
Replies (36)

@Pudel89 

 

How long did you test this? Or how long since you remove it?

@Pudel89 

MEI: do you mean the Intel Management Engine Interface?

Thank you!

Dears, I have a solution for this I tested and it's working, it's a temporary solution waiting another update from Microsoft.
I have disabled the sleep hibernate mode on windows 10 by going on settings ==>System==>on the left barre click on Power & sleep==> on right panel click on "Additional Power settings" ==> then chose your power plan by clicking on "Change plan settings"==>Change Advanced power settings"==>click on Sleep option in the list==> go to the "hibernate After" and chose "Never" option or type "0 Minute" for both cases.
It's work.

note that you can escape all this by going on icon battery and right bouton then chose power setting.
I hope this hopeful.

@Unes I have had to ONLY enable Hibernate to allow people to use their laptops without shutting down. Normal sleep modes crash all the time. I set SLEEP to Never and allow Hibernate.

2 Bronze
2 Bronze

We use Microsoft Surface Book 2's as well as Dell Latitude 5300's and out of about 20 laptops, we have at least 7 experiencing this issue. Fresh installs have the same issue on both systems. This only started happening once we updated to v2004.

In addition to the Hibernation BSOD, we have had about 5 of the 7 systems experiencing BSOD while working, sometimes multiple times per day. This also only started after v2004 was installed. These 5 systems are all Surface Book 2s. No Dell 5300s have experienced a BSOD while working....only in hibernation.

Everything I read says to make sure drivers are all updated. Surface Books get their driver updates through Windows Update. So, they are all up to date, yet, still receive errors.

I believe this is a Microsoft Update issue and not a Dell issue.

Even MS Surface Hubs fail to wake from Sleep with the current version of Windows

https://docs.microsoft.com/en-us/surface-hub/surface-hub-2020-team-update-known-issues


Surface Hub 2S intermittently fails to resume from sleep Surface Hub 2S may intermittently fail to fully resume from sleep and appear to stop responding on a screen showing the Microsoft logo. Try unplugging your device and plugging it back in. To prevent this issue: 1. On Surface Hub, open Settings and enter your admin credentials when prompted. 2. Navigate to Surface Hub > Session & power. 3. Under When the device goes to sleep, use this power setting, select Connected Standby. 4. Under When no one is present, put the device to sleep after, select Never. Microsoft plans to fix this issue in a firmware update prior to the final release of Windows 10 Team 2020 Update.

2 Bronze
2 Bronze

I've received at least two reports from colleagues with Latitude 5500 laptops of the pdc.sys BSOD with the PDC_WATCHDOG_TIMEOUT error on Windows 10 2004, and had it happen to my Latitude 5500 also. I tried many of the things referenced in this thread, as well as upgrading to 20H2, and the only test that made the BSOD stop was configuring the laptop to never go to sleep.

In the end, in my situation, I found that the BSOD only stopped when I uninstalled Trend Micro AV. It worked when I uninstalled it while upgraded to 20H2, and when the problem came back after reimaging the laptop to a freshly updated version of my employer's Windows 10 2004 install (which includes Trend), the issue went away a second time when I removed Trend again. I'm sorry that I don't have any more details, other than that my laptop is working fine now, and we're now preparing to see if Trend Micro has any answers.

@wifiholic thanks for your feedback. Interesting you mentioned Trend AV. We are running Trend WFBS on ours. Are you running this or a different version like ApexOne? Thanks!

For what it's worth, we're using Trend Micro OfficeScan.

Hello

I'm trying to deploy multiple DELL Latitude 5300. I'm getting the same bsod as described before when im resuming from sleep.No error on other brands (hp, lenovo..)

We also have TrendMicro Apex One installed.

Did you open a case with TrendMicro support ?

Thank you

Top Contributor
Latest Solutions