Latitude

Last reply by 06-01-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
20832

Latitude 5400 Sleep Issues

We recently received over 100 Latitude 5400s. We have set all sleep and hibernate options to never go to sleep or hibernate. However after 24 hours they go to black screen, power button fades to black, and you cannot ping, RDP, or scan. We image them via SCCM, all drivers are up to date, and we doubled checked the settings. 

The NIC has link lights at all times, and the computer will wake once you touch any keyboard key. But if you don't physically wake it up it thinks it is in sleep, or even hybrid sleep mode, which it doesn't even have. This is causing a problem since they are not receiving updates via SCCM, and we have 50 of these machines at a remote site that we cannot log in to.

Replies (22)
8896

The trick that seems to have been working on one machine was Disabling the "C-states" located in the BIOS. This was suggested in another thread on Dell forums. We did also make sure that sleep states for Windows was disabled and that the green low-power modes for the ethernet was also disabled.

We've had one computer that we noticed was having issues dropping network connections and 'resume' once keyboard or mouse was moved. After disabling "C-States", things seem to work as expected.

 

 

8799

Unfortunately I am also reporting my 4 of 4 my Latitude 5400 are exhibiting poor sleep behaviour and more often than not they are not resuming from sleep cleanly, and may not turn back on, or after some delay will BSOD and reboot. The computer reports entering into connected standby prior to the BSODs.

This is what I am using:

  • Dell factory Windows 1909 image
  • Upgraded to Windows 2004 update
  • Upgraded all drivers and BIOS to current as of June 2020 using Dell Command
  • BIOS v 1.7.4

BSOD Details:

This was probably caused by the following module: pdc.sys (0xFFFFF8041829E5D0)
Bugcheck code: 0x14F (0x4, 0x2, 0xFFFFF8041829E5D0, 0xFFFF9D8FD66E5A50)
Error: PDC_WATCHDOG_TIMEOUT
file path: C:\WINDOWS\system32\drivers\pdc.sys
description: Power Dependency Coordinator Driver
Bug check description: This indicates that a system component failed to respond within the allocated time period, preventing the system from exiting connected standby.
This is likely to be caused by a hardware problem.
The crash took place in a Microsoft module. Your system configuration may be incorrect. Possibly this problem is caused by another driver on your system that cannot be identified at this time.

Notes:

  • 2004 no longer supports Connected Standby alterations via Registry. Its also called Modern Standby now in Microsoft literature... but not in the OS itself.
  • I have removed Sleep modes for users and added Hibernate instead... not too many complaints yet but its early days.

Here is System Information XML from Dell Command for anyone else interested in software versions

<?xml version="1.0" encoding="utf-8"?>
<ArrayOfSystemDetailsEntryItem xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SystemDetailsEntryItem>
<ComponentType>Operating System</ComponentType>
<Display>Microsoft Windows 10 Pro (x64)</Display>
<Version>10.0.19041</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>BIOS</ComponentType>
<Display>BIOS</Display>
<Version>1.7.4</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Realtek(R) Audio</Display>
<Version>6.0.8940.1</Version>
<Device>0236</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Host Bridge/DRAM Registers - 3E34</Display>
<Version>10.1.14.7</Version>
<Device>3E34</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)</Display>
<Version>10.0.19041.329</Version>
<Device>9DED</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>PCI standard RAM Controller</Display>
<Version>10.0.19041.1</Version>
<Device>9DEF</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) SPI (flash) Controller - 9DA4</Display>
<Version>10.1.15.6</Version>
<Device>9DA4</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Gaussian Mixture Model - 1911</Display>
<Version>10.1.7.3</Version>
<Device>1911</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Thermal Subsystem - 9DF9</Display>
<Version>10.1.15.6</Version>
<Device>9DF9</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>I/O LPC Controller - 9D84 for Intel(R) 300 Series Chipset Family On-Package Platform Controller Hub</Display>
<Version>10.1.15.6</Version>
<Device>9D84</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Smart Sound Technology (Intel(R) SST) OED</Display>
<Version>10.23.3349.218</Version>
<Device>0222</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Smart Sound Technology (Intel(R) SST) Audio Controller</Display>
<Version>10.23.0.3349</Version>
<Device>9DC8</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) PCI Express Root Port #8 - 9DBF</Display>
<Version>10.1.15.6</Version>
<Device>9DBF</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Realtek PCIE CardReader</Display>
<Version>10.0.18362.21317</Version>
<Device>525A</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) SMBus - 9DA3</Display>
<Version>10.1.15.6</Version>
<Device>9DA3</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Wireless-AC 9560 160MHz</Display>
<Version>21.70.0.6</Version>
<Device>9DF0</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Chipset SATA/PCIe RST Premium Controller</Display>
<Version>17.5.3.1026</Version>
<Device>282A</Device>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Alps Pointing-device Driver</Display>
<Version>10.3201.101.312</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel 825xx 10/100/1000 Ethernet Network Drivers</Display>
<Version>25.0.1.0</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Realtek USB Audio</Display>
<Version>6.3.9600.2215</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) HID Event Filter</Display>
<Version>2.2.1.377</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Wireless Bluetooth(R)</Display>
<Version>21.80.0.3</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Serial IO GPIO Host Controller - INT34BB</Display>
<Version>30.100.1915.1</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Management Engine Components</Display>
<Version>1938.12.0.1317</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Application</ComponentType>
<Display>Dell Power Manager Service</Display>
<Version>3.6.0</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Application</ComponentType>
<Display>Dell Update - SupportAssist Update Plugin</Display>
<Version>5.1.0.11858</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Application</ComponentType>
<Display>Dell Command | Update for Windows 10</Display>
<Version>3.1.2</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>FRMW</ComponentType>
<Display>PM981a NVMe Samsung 256GB</Display>
<Version>1530.2029</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Application</ComponentType>
<Display>Dell Digital Delivery Services</Display>
<Version>4.0.52.0</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Graphics</Display>
<Version>26.20.100.8141</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel Software Installer</Display>
<Version>21.70.0.6</Version>
</SystemDetailsEntryItem>
<SystemDetailsEntryItem>
<ComponentType>Driver</ComponentType>
<Display>Intel(R) Dynamic Tuning</Display>
<Version>8.6.10401.9906</Version>
</SystemDetailsEntryItem>
</ArrayOfSystemDetailsEntryItem>

8816

2 Bronze
2 Bronze
8842

Microsoft Windows 10 uses Modern Standby instead of S3 and problems are here.

https://docs.microsoft.com/en-us/windows-hardware/design/device-experiences/modern-standby-vs-s3

I switched to old S3 power mode and all works fine as usual.

How to do it?! Just change the CsEnabled to 0.

You can use ready ".reg" file, download and open it.

http://notebookcheck.com/fileadmin/Notebooks/Sonstiges/connected-standby-disable.reg

or you can manually create ".reg" file, save and run or edit Windows Registry directly

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power]
"CsEnabled"=dword:00000000

You need restart your laptop after it.

 

If you want to restore the default mode - Modern Standby, you need change CsEnabled to 1.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power]
"CsEnabled"=dword:00000001

8732

Sorry @PiT13 that is no longer applicable to Windows 10 2004. It works in 1909 and 1903, but not 2004.

12643

my 5400 also has such an error, it is very bad that dell allows such an error. I hope it will be improved. currently the button and cover turn off the machine

2 Bronze
2 Bronze
7214

If you're having this issue and the system is docked try this:

https://www.dell.com/support/kbdoc/en-us/000130111/wake-from-sleep-with-d1000-d3100-d6000-docks

 

 

2 Bronze
2 Bronze
7094

Latitude 5401 purchased Dec '20, running Win 10 20H2
(posted 29th Dec '20 - hope this helps someone)

Like others in this thread, I want to be able to close the lid of my laptop and know that it has gone to sleep and is not going to wake up in my laptop bag, and drain the battery. 

Legacy Standby S3 should still be made easily available as an option. Who cares about resuming an extra few seconds quicker? I'd rather know that my laptop won't suddenly start up on its own.

I restored Legacy Standby S3 as follows:

  • BEFORE: run cmd - powercfg /a 

    image.png 
  • In bios --> Performance --> C states Control - turn off C states
  • image.png
  • Registry: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power:
  • right click on Power (left tree), new DWORD, name "PlatformAoAcOverride" value 0
  • Restart
  • AFTER: run cmd -  powercfg /a  - Standby S3 is restored

    image.png

5500

Whoaaa man, thank you very much. It works!

2 Bronze
2 Bronze
1641

Was researching this, the Dell 5411's have the issues as well, the workaround @centicon  used this works on Win 10 v21H2 as of 4/22/22 

Latest Solutions
Top Contributor