Highlighted
lup374
1 Copper

Latitude 5580 heats up, won't start

Specs: i7-7820HQ, nVidia940M, 16GB

I left the laptop on battery power, writing to an external hdd and when I came back, found it turned off and now I can't get it to start again.

When I plug the adapter, the CPU starts heating up immediately, but no other sign of life - nothing turns on.

Do you guys think it can be fixed or the CPU/MB are fried?

Thank you

 

0 Kudos
2 Replies
JOcean
4 Ruthenium

Re: Latitude 5580 heats up, won't start

By heating up, do you mean it gets so hot that you can feel it through the case? If so then very possible the CPU or motherboard is having problems. Try a reset but it sounds like a more serious problem. disconnect the battery and unplug the adapter. Now press and hold the power button for 30 seconds. Then reconnect everything and try to boot.

Do you see any flashing lights, hearing beeps, and if it is getting that hot do you smell anything like burnt electrical components?




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built ASUS Z170K i5 6600
Real work on an Inspiron 15 5575
0 Kudos
lup374
1 Copper

Re: Latitude 5580 heats up, won't start

When I plug the adapter, I can feel the heatsink getting hot after 10-20 seconds. No lights, no beeps, nothing. I have no hope for it anymore; got a second-hand Precision 5510 in the mean time and researching the web for a new motherboard for the Latitude. Thanks for the reply, good day!
0 Kudos