Latitude

1 Copper

[Latitude 7490] No Driver for Touchpad in Windows Server 2016/2019

Hello. I need a help with the touchpad installation in the Windows server product line. I've installed the Windows Server 2016 and 2019 in a Latitude 7490 and had issue with the touchpad in both OS.

  • The issue is that the touchpad doesn't work in the SO

The touchpad works perfectly in the installation part (that loaded by a bootable USB stick) but not when the OS is completely installed in the SSD. Appears in the "Device Manager" the "ACPI\VEN_DELL&DEV_081C" device as "Other devices". I've tried to:

  • Load the Win10 driver
  • Use the Driver Easy
  • Use the Win7 driver

None of these attempts worked. It's funny because it works in the installation program (WinPE) and stops working when the SO is loaded from the SSD...
**Actually I'm using an external mouse.

Any ideas?

Thanks

Labels (1)
Reply (1)
2 Bronze

I’m using a Latitude 7280 and I am having the same issue. I’ve tried pretty much what has been mentioned already. Any help is appreciated.

Top Contributor
Latest Solutions