Highlighted
Hans89
1 Copper

Latitude E5540 - can't get past post, blinking cursor

My dell works fine for years, now it stopped working and hangs on post. When I turn on my Dell laptop, the screen lights up and the Dell logo appears when it disappears, I only see a blinking cursor in the upper left corner. when I try to load the bios (F2) or the boot menu (F12), I see a status bar below the Dell logo and then a blinking cursor in the upper left corner.

I've tried the following things

  1. Remove power supply and battery, try on power supply only and vice versa
  2. try booting from other media but can't access the boot menu do
  3. Remove CMOS battery for a minute, an hour, a night
  4. Remove CD-drive, wi-fi module and SMART card reader
  5. Replace the hard drive for another one
  6. Replace RAM module for another RAM bank and try both slots

 

Is there someone who recognizes this problem or can help me to solve this problem?

Thank you very much

Labels (4)
0 Kudos
3 Replies
Moderator
Moderator

Re: Latitude E5540 - can't get past post, blinking cursor

 

Hi Hans89,

From all the troubleshooting you have done it sounds like it's probably the motherboard that is faulty. Are you able to access the BIOS/Boot Menu if you try starting the system with no HDD attached? What happens if you try a diagnostic boot? (hold down the Fn key whilst you power the system on)

 


DELL-Alasdair R
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 10am-5pm GMT (BST)
Get Support on Twitter @DellCaresPro


0 Kudos
Hans89
1 Copper

Re: Latitude E5540 - can't get past post, blinking cursor

Hi DELL-Alasdair R,

Thank you for your answer.

I've tried to start the laptop with FN + power on and the laptop goes on gives the dell logo with in the right top of the screen a text that diagnostics are started but then continues to hang on the blinking cursor...

When I look at the status LEDs (wifi/power-on/battery/HDD), the LED wifi is off, power-on steady on and the battery and HDD are flashing.

Also I can't acces bios or boot menu everything stops at the blinking cursor.

I'm afraid that I have a hardware fault in the main board.

If there is any other option please let me now?

 

Kind regards, Hans

0 Kudos
Moderator
Moderator

Re: Latitude E5540 - can't get past post, blinking cursor

 

Hi Hans,

The Blinking-Blinking-Off LEDs indicate System failed on hard drive initialization OR System failed in Option ROM initialization.

https://www.dell.com/support/article/us/en/04/sln309632/a-reference-guide-to-the-latitude-notebook-a... (listed under E-series Diagnostic LEDs > Legacy)

This would make me think the HDD controller on the motherboard has failed, especially since it's happening with more than one HDD. Are you able to test the original HDD in another system to make sure it is still ok too?

Unfortunately I don't think there's any other option but to replace the motherboard, which for a system of this age probably won't be economically viable.

 

 


DELL-Alasdair R
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 10am-5pm GMT (BST)
Get Support on Twitter @DellCaresPro


0 Kudos