1 Nickel

Latitude e5480 Network Issue with WD15 Dock

Hi Everyone,

My workplace has recently begun rolling out e5480s as our laptop of choice, connected to WD15 docks. The ones imaged with Windows 7 seem to work well enough, but the ones on Windows 10 all experience a peculiar issue: one out of every 5 or 6 dockings/undockings from the WD15 results in the corresponding network interface to stop resolving the gateway and self-assign an IP, at which point the laptop becomes dead weight - Windows 10 starts acting like all its resources are chewed up and all applications become non-responsive. Even switching back to the other network interface doesn't help, as the issue now affects all interfaces from this point forward. You can't even restart because the user account can't log off - you have to hard restart.

IPv6 is disabled, only IPv4, on all of the network interfaces, with NetBIOS disabled across the board. We have a fairly mixed environment, and so far it's only the 5480s that are running Windows 10 and using a WD15 dock that have this issue. And the event logs give no details, as it just shows the network event of the new interface (wired when docking, wireless when undocking) toggling, then a list of other applications and services complaining about no network connectivity - it doesn't give any details as to why the interface has a self-assigned IP, or why Windows starts locking up when it happens.

Here are my troubleshooting steps so far:

  • all of the command prompt goodness: flushedDNS, did a release/renew of the IP, reset Winsock, flushed the TCP/IP stack
  • turned off power management on all interfaces
  • updated all drivers, including dock drivers to their latest versions, and the laptop BIOS to the latest
  • updated the firmware on the docks, including the ethernet controller
  • changed the hostname in case there was a conflict
  • turned off the Computer Browser service, as we've had previous issues with 5480s and browser elections causing network issues
  • Changed all network discovery services to automatic in case it wasn't toggling those properly
  • took the laptops off the domain in case it was a group policy thing
  • formatted the laptops and reconfigured from scratch
  • changed out the laptops and docks for ones fresh off the shelf in case we had a bad batch
  • Upgraded to Windows 10 ver 1803 in case it was a problem with 1607 (our image uses 1607)
  • Used a fresh 1607 install without any updates, in case there was a bad driver or Windows 10 update that got applied after imaging
  • uninstalled Citrix Receiver, as I read somewhere that it can cause conflicts and it's part of our image
  • reimaged without using our driver pack, in case there's something corrupted in that driver pack

The only thing I haven't tried so far is not using our image *at all* (i.e. formatting with an OEM disc). However, all other Dell laptops we use running that image don't have any issues; it's just the 5480s exclusively. For example, we have 7490s in the environment as well on the WD15 docks using the same image that have no issues whatsoever.

It's especially odd in that undocking/docking works fine 80% of the time. It's like a game of Russian Roulette when you go to a meeting - is this the one that's going to lock it up?

I found this post of someone having a similar issue, but there was no solution: https://community.spiceworks.com/topic/2089446-latitude-5480-ethernet-connectivity-issue

Does anyone have any ideas? I'm getting desperate at this point, and I feel like I've tried everything.

Thanks in advance.

0 Kudos
3 Replies
1 Nickel

Re: Latitude e5480 Network Issue with WD15 Dock

If anyone stumbles across this post wondering if I ever got a resolution, I was able to narrow it down to our third-party firewall. Apparently it is an extremely rare issue that only happens in specific conditions (and I was [un]lucky enough to have the golden combination in my environment), and I'm working with the vendor now on debugging it.

0 Kudos
1 Copper

Re: Latitude e5480 Network Issue with WD15 Dock

Hi, i have the same problem with the dell latitude 5480, every single time i plug the notebook to the dock station/unplugged the windows 10 just stop working and i have to hard reset. What you do for fix this problem?
0 Kudos
1 Nickel

Re: Latitude e5480 Network Issue with WD15 Dock

For our environment, it ended up being a compatibility issue with our antivirus. We called the vendor (TrendMicro) and they helped us solve it. Turns out OfficeScan was treating the heuristics of the dock like it was malware, and a registry edit disabling the appfilter solved the issue. Try uninstalling your antivirus as a test. If you can dock/undock just fine without the antivirus, maybe give the vendor call.
0 Kudos