Latitude

2 Bronze

No data wipe in bios

I have a Dell Latitude E7240 laptop with I presume an SSD. I can't get into Windows and I want to do a secure erase of everything on the internal drive. According to this support page, there's an option in the bios to do a data wipe. But when I enter the bios, the option isn't there.

https://www.dell.com/support/article/sln312291/dell-data-wipe

What should I do in this situation?

Replies (8)
7 Thorium

@ShonenRonin  That might only be available for SSDs that have native support for Secure Erase, which isn't all SSDs.  You can use the free DBAN tool to wipe the SSD.  You'd need some other PC to create a bootable flash drive containing the utility, but at that point you just boot your system from that flash drive, select your SSD, and wait for the erase to complete.


I remember reading that DBAN was not suitable for SSD. Maybe I was wrong? I'll look into it.

@ShonenRonin  Well it does generate a lot of write activity, which does add wear to an SSD, but if you want to wipe an SSD that doesn't support Secure Erase, then actively writing to all of the sectors is your only real option.  (If you're curious, the way Secure Erase works is that the SSD has hardware-level support for encryption, and it's always enabled even if the SSD behaves unencrypted by not protecting the encryption key it's using.  Since all of the data on the disk is encrypted with a key, a Secure Erase just requires the SSD to actively overwrite the key itself, thereby rendering all of the data on the SSD inaccessible without having to actively destroy it.)


I've read about a tool called PartedMagic that can apparently do a secure erase of an SSD without causing any wear. Do you know if that would be good to use?

@ShonenRonin  The only way to do a Secure Erase without writing data to the cells is if the SSD supports it.  I suppose it's possible that your SSD might support it and therefore PartedMagic could leverage it even if the Dell BIOS option isn't there for some reason, so that may be worth checking, but if your SSD doesn't support Secure Erase, then despite PartedMagic's name, there is no other "magic" way to erase an SSD without any wear.  That said, writing to all cells of the SSD once isn't a meaningful amount of wear anyway.  SSDs have write endurances that VASTLY exceed what a typical user will ever write to them in the typical amount of time they'll keep them.  As just one data point, my SSD has a write endurance of 600 terabytes written.  I've been using it every day for 9 months now and I've written 5 TB to it in that time -- so at this rate my SSD will last 90 years.  A single pass across your entire SSD, or even multiple passes, is not going to make a difference.


In that case I will just use DBAN. Thank you for your help.

2 Bronze

Update the BIOS for the option to show up

do not udate your Bios or set it back to default

My dell latitude e7240 with Windows 10 is totally <Profanity removed> since I did it !

Right after it crashed to "invalid partition table" or the blue sreeen of death "no boot device found"

Thanks a lot windows 10 ...

Good job Microsoft as always ...

Tried everything to fix it I mean everything !!! hours of bootable usb keys even tried running it on an external wih Desbian nope ... "uncompatible hardware" waiting to receive a "redkey" from the original website now after hours of my time lost ...

If anyone wonders why the Windows 10 upgrade and complete download is free over the internet no wonder they give it for free !!! It's the worst version they released so far ! Nobody in their right mind would install it a second time on their laptop if they're able to save it ...

Top Contributor
Latest Solutions