Latitude

Last reply by 12-06-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Serial port on docking station K13A not working

Hi,

I got a docking station K13A and when i try to connect via the serial port (com1), the connection work but there no communication at all. They sent me a new one, thinking that the problem was the docking station itself, but same problème.  Note that my serial port on my laptop work fine.

Any idea of what can be the problem?

Thx.

 

Jay

Replies (7)
2 Bronze
2 Bronze

So the important thing here is that, when the laptop is docked, the dock doesn't simply translate the existing serial port on the laptop to the one on the dock, it adds a USB serial port.  If you had physical access to the port on the laptop, it would still work even when docked (just as jphughan was wondering about).

In practice, this means that Windows will still detect COM1 and it will appear as active and available to any software that wants to try and communicate via that port but, obviously, nothing will happen -- you're not plugged into COM1!  Instead, you will need to configure whatever software you are using to communicate via the USB Serial Port that gets added when the laptop is docked (check Device Manager -- for me, this is COM3).

ports.jpg

 

This makes sense once you think about it, but is non-obvious when troubleshooting, I think -- maybe because the port addition is basically invisible to the user when docking: we never get any indication a port is being added.

Anyway, I hope this is helpful and solves your issues!

 

(Edited to remove erroneous punctuation.)

@jphughan  Thx for your suggestions.

Someone from Dell tech support called me and connected on my laptop and tried the bios update etc., but still not working. They should be back with other solutions. To be continued....

@Jay2021  Ok, then unfortunately I don't know what else to suggest other than maybe a BIOS update in case that resolves some strange issue that might be causing this, or exploring the BIOS options in case there's somehow an option to lock out the dock-based serial port, but I can't imagine why there would be an option to lock that out while keeping the built-in serial port usable rather than allowing both or neither.  Sorry I can't be of further help here!


@jphughan  The serial port on the laptop is physicly blocked while docked, so i cannot use it. And i only got 1 Com1 port in Device Manager while docked.

@Jay2021  Just to confirm since it's been quite a while since I last worked with serial ports, when your system is docked do you still only see a single serial port at COM1 in Device Manager, or do you see an additional serial port?  The reason I ask is that if you're able to use the serial port on the laptop itself even while docked, then I would expect the serial port wired to the underside dock connector and therefore available through the docking station would be sitting on its own COM port.  If so, you'd need to switch your application to use whatever other COM port is showing in Device Manager when you're docked.  But reading your first post again I notice that you didn't say that the COM port on your laptop works specifically while docked, so I guess it's possible they share a common controller chip and you can only use one at a time.  And in that case I'm not sure how to account for how multiple laptops used with multiple docks would all have problems using the serial port on the dock.  I don't think there are any BIOS options to disable the dock serial port specifically.


Hi jphughan,

I also tried with another laptop, but same problem.

7 Thorium

@Jay2021  If you've already tried another dock, then there may be an issue with the E-Port docking connector on the underside of the laptop itself.  That could account for the system's built-in serial port working while the dock connector doesn't even on multiple docks.  But if simply blowing some compressed air or something into that connector doesn't resolve the issue, unfortunately there's no easy fix since that connector is part of the system motherboard.


Top Contributor
Latest Solutions