Latitude

Last reply by 08-05-2022 Unsolved
Start a Discussion
1 Copper
1 Copper
649

Touchscreen not working, I2c HID Device Issue

 Latitude 7390 2-in-1 touchscreen not working. In device manager under human interface devices, the I2C HID Device is listed twice. The device status for the first listing says: This device cannot start. (Code 10).  The other one says the device is working properly.

 

I have tried to uninstall one and both several times but no success. Any suggestions on how to resolve this is much appreciated.   

 

Replies (3)
Moderator
Moderator
616

We tried reaching you on a private message but did not receive a response. Please feel free to reply to the private message whenever you are available.


#IWork4Dell
Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

452

Having same issue with a Dell 7390 2-in-1.

2 Bronze
2 Bronze
150

I have the same issue with dell latitude 5410, did you get it fixed?

Latest Solutions
Top Contributor