Last reply by 08-04-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (383)

Hi all,

My colleague Alan is out of the office this week, however we have had an update from our Engineering teams regarding this issue.

They are currently still looking for the root cause of the issue itself but have advised that disabling Link State Power Management as @Artreas has done should function as a workaround until they have addressed the root cause.

To do this in Windows 10, search for Settings > click System > click Power & sleep > Additional power settings > Change plan settings (next to your currently selected power plan) > Change advanced power settings > scroll down to PCI Express and click the + sign > click the + sign next to Link State Power Management and set On battery and Plugged in to "Off" > Click Apply.















@Artreas - if you please let us know if disabling Link State Power Management has helped, it would be greatly appreciated.

John C

Dell EMC
| Commercial Social Media Quality Lead


I have the same issue.  Updated all drivers and BIOS.  swapped CAT5 and port.  turned off power saving settings on all applicable NICs. 


The dock for Laptop #2 still dropped network.  I have now enabled the Block Sleep option in BIOS, and disabled the Power Management for the PCI Express Link State in the active Windows power options profile.  The WD19 180W dock is quickly becoming worse the the WD15.

2 Bronze
2 Bronze

Same here.  We order 5591 Latitudes along with WD19 180W "docks".  Two out of the three users are now experiencing drops in hard wired network.  I have a lot more of these to deploy and this is going to get messy if the docks are all bound for failure.  After the abysmal experience we had with the WD15 and our 5580 Latitudes, this is not something that I want to inform the higher ups about.

Laptop 1 has the CAT6 plugged directly into the laptop and does not exhibit issues.

Laptop 2 currently has the CAT6 plugged into the dock.  USB Selective Suspend is turned off in power, Power Management on the Ethernet port has been disabled.

All drivers are current through Dell Command Update.  Currently waiting to hear from Laptop 2 while building the rest of these machines.


Thanks kdhatt2 for your feedback.


Are you also seeing it drop the Docks USB port(s) as well? 

have you logged a case with Dell- the more regions/ Countries which log this the better.


Saw this issue for the first time on a new 5400 we got yesterday. Tried two different WD19 docks and both had the same issue.  Dock info is as follows:

Reg Model: K20A

<Service Tag removed>

Same exact behavior of wired connection dropping every few minutes.  Off the dock using wifi there seems to be no issue.  


Thanks. i would encourage others to use private messages for private info. But please continue to post helpful info to this forum for knowledge sharing purposes. 


I have exactly the same issue, what's also annoying is after rebooting the laptop the event logs don't provide any info as regards to the problem


@jaybird283 thanks for the case reference, I have removed it from the public forum now. I have added it as another reference point for engineering. I would recommend continuing to work with your case owner to avoid any confusion.

As soon as I can provide an update on the issue I will post it here.


Social Media Support
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro


@qm4101 thanks for the additional info. Do you mind responding to my private message please so I can pass your case details onto engineering for further analysis.

Have you tried the workaround that was posted to see if it is a temporary fix whilst engineering investigate this further?


Social Media Support
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

Latest Solutions
Top Contributor