Last reply by 09-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (393)

there is finally a firmware update for the WD19 docks!, A04 no troubles since I have updated my dock...


Just a heads up...Dell hasn't been answering this thread for a while. They closed it a couple months ago.

But, it's good to know that the 5520's also have the issue. My company is getting a bunch in soon.

If you haven't updated all the firmware and drivers with the dock plugged in, that might resolve most of the issues you're having. If not, call Dell and make them replace it. This is a known issue to them.

2 Bronze
2 Bronze

I am having this same issue with Latitude 3410's and WD19 docking stations.

Is there like a power setting somewhere that would cause the laptop to go to sleep and then not be able to come out of sleep? I mean I have 15 people constantly down for work after a break or lunch and first thing in the morning. I don’t have any power settings configured in group policy, when we did the only computers affected are these 3410 machines.

I have unchecked the USB stop devices in windows 10. I have updated all the drivers on the laptops and the docking stations. I have gone through forums reading of this same issue happening over the last three years with various models of laptops all without any solution that works.

I have turned off the PCI Express settings. Really the only thing we have found that works is to never have the computer try and conserve energy by turning off the screen or sleeping. Or have users turn their computers off for lunch, after work, or for breaks so they can turn them on when they get back into the office.

I have also followed the directions of configuring the BIOS with the settings required to use the Dock.

Enable External USB port

Enable USB Boot Support

Enable USB PowerShare


There is no BIOS setting for Dell Type-C Configuration

There is no BIOS setting for Thunderbolt Adapter Configuration


Replacing the docking stations isn’t helping the situation, the fact all 15 of these laptops all face the same issue points to a defect in the laptop itself. 


They're not going to sleep, they're going into hibernation. Turn off hibernation either manually in the power settings in the control panel or here's a reghack. Copy this into a text editor and save as (something like) Hibernation_Off.reg.


Windows Registry Editor Version 5.00



Drop it on the desktop and double-click it. Reboot might be needed.


Not sure why Dell Cares has not posted this before, but it turns out there is a BIOS setting you need to enable. Under Power there is USB Wake support that needs to be enabled. 

Apparently it turns off "unused" USB ports to conserve energy. In my case, when users come back from lunch or break the system attempts to restart the USB device that is powered off and fails which requires you to reboot to resolve the issue. 

Here is the dell support page, below that is a short description from that page about USB Wake Support. 

Why is there no wake from sleep using only on-board keyboard and touchpad with Dell eighth generatio...

What is USB Wake Support?

There is a BIOS setup setting on some systems called USB Wake Support, which can enable or disable the ability of a USB device to wake the system from the S3 state (Sleep).

When enabled, USB devices can wake the system from S3 (example: USB mouse, USB keyboard). Furthermore, on AIO (All in One) systems, the touch screen is a USB input device and also has the capability of waking the system.

When disabled, USB devices cannot wake the system form S3. Disabling this setting can help a user save power by turning off power to the USB ports in S3.

USB Wake Support does not function on battery power; that is, if a portable system on battery power enters S3, USB devices will not be able to wake it up. Whether the USB devices are externally powered or derive their power from the system’s USB port makes no difference. The determining factor is whether or not the system’s USB ports are powered and able to detect USB traffic. Upon entering S3, the system will turn off power to the USB ports in order to conserve power.


I not sure will this works but Dell did a second replacement and so far it looks fine now.. the background story was like this:

My first unit that I have purchased has the issue and as subject mentioned. Thereafter, I bring this up to Dell and they replaced a unit for me and then second unit issue is the fans keep running at high speed. So I requested to have a unit to be replaced again and so far, it works pretty well.

Do note; My laptop is running under domain environment and I do have other user using other model laptop with this docking station and is running fine.


I have exactly the same problem with 3 WD19's.
After all this time I am just going to call support and get them replaced with WD19S units as I am sick of waiting for a solution.

2 Bronze
2 Bronze

I feel the need to contribute here. I've been using some Dell WD19S docks here in NZ with non-dell laptops (mainly acer) due to shortages of Type-C docks.

I've found them pretty good but I have had issues with the Ethernet dropping out with a specific model of Acer.

I have one in the workshop setup and it works like a dream with an HP Zbook and an Acer P414 (new model with full Thunderbolt) but with an Acer P614 I get the dropouts in ethernet.

When the ethernet drops we get the USB device has malfunctioned and the ethernet has disappeared. 

With the laptops in my workshop I've copied 70GB or more of data over the ethernet and they don't drop - On the P614 sometimes something as simple as an OOKLA speedtest online is enough to kill it.

I'm going to go onsite and explore options but I've tried the Dell recommended Realtek driver and the latest Realtek driver from and neither help. I've checked the Firmware and the versions reported are the same as what the latest download offers.

The Acer in question doesn't have full thunderbolt - Its Type C with DP over type c (And is working with two desktop screens) and Power delivery and is charging from the Dock fine.

I'll report back if I find anything that appears to make it stable.

I'm not sure Dell should be blamed for a bad dock - I think its more about the Type C implementation on the Laptop in question. Modern laptops with full Thunderbolt seem to work well - Lesser Type C implementations have issues perhaps?


Well, let me put it to you this way...many, many hours of troubleshooting went into this problem. I had Dell engineers working with me and it wasn't until they released the dock firmware that the problems started resolving. At one point, they tried to blame it on my OS build, so I took one straight out of the box and plugged it into the dock. Nope same issues.

Neither the docks, nor the laptops that we tested, were the thunderbolt series.

The problem didn't exist if you plugged everything (that you could) directly into the laptop.

The problem didn't exist if you plugged the laptop into a Lenovo dock. I told the Dell engineers this and they weren't happy that I was experimenting with Lenovo products. lol

The problem did exist if you plugged a Lenovo laptop into the Dell dock.

And again, the nic and usb drops resolved after the dock firmware was released. The resolution/flickering/camera drop issue we were having also resolved. For some reason, the dock effected one particular model of monitor that had a built in camera/speaker/mic. We couldn't get the resolution up to 1920 x 1080 (it would only go up to 800 x 600), but other models could.

My guess is they had these docks set to power save and the users had no way to change that.

BTW, we did test the thunderbolt dock with a thunderbolt laptop and had the same issues. Again, it wasn't until they released the firmware update that things resolved.


I'm already on the latest firmware and my issues are far fewer that yours - The dock is powering the laptop reliably and dual monitors out is flawless (1 x USB 1 x HDMI) - The only remaining problem I have is the Ethernet dropping out - Its not the USB Hub component as a wireless mouse/keyboard receiver continues to work.

I think this might say more about the laptop as this specific model (Non-dell) seems to have a week type C implementation. It does do power delivery and Display port over USB but its not full thunderbolt. The newer generation of the same class of Acer laptop appears to work flawlessly as does an HP Zbook.

I'll do a bit of trial and error on the power saving settings to see if I can resolve it. Otherwise I might have to swap the dock for another when I can actually get one - All brands of Type C dock (Real dock, not just an unpowered Port replicator) are scarce as hens teeth at present in NZ supply chain - I have wholesale access to Lenovo, Acer, Dell, HP, ASUS, Targus and Kensington amongst other brands.

In general I've actually found the Dell units to be quite compatible across brands of Laptop and the pricing is very competitive.

Latest Solutions
Top Contributor