Latitude

Last reply by 09-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
125551

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (393)
3595

My experience;

After a third replacement of the docking station, so far it works quite well except every brand new day I got to disable and re-enable the NIC once because it couldn't receive an IP address from my DHCP server. The docking station always started, it's a brand new day with an APIPA addresses. 

 

2 Bronze
2 Bronze
3406

We have 2 new Latitudes that have the same problems with new WD19 docks. Any time you wake up the PC attached to the dock it has to be rebooted to restore the NIC connection.  I thought it was just 1 having the issue but when I asked the 2nd person last week if they had issues they were like oh yea since I got it they reboot it every morning when they come in the office

2 Bronze
2 Bronze
3486

If it is just the network connection you keep losing you can try using a ethernet to USB adapter. I have 2 people setup that way while I play the replacing docking stations game until I get one that has a functioning network port. That is if you enabled the Enabled USB Wake support in the BIOS, if you have not done that yet give that a shot. 

For some reason it is not enabled by default but it shuts off USB ports to conserve power, but then the OS can't turn it back on and you are forced to reboot. 

2 Bronze
2 Bronze
3554

We also experienced network dropouts with the latest generation CPUs (mostly 11th generation).

All problems went away after we switched to the latest driver from Realtek. Dell driver is from 2020. Give it a try.

https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit...

 

3359

Installed all firmware, driverr updates and still the same problem. Everytime coming out of sleep WD-19-TB drobs the hub RJ45 internet connection. When will Dell fix this issue? Going on since 2019 have latest drivers installed for everything related to the dock. It is a defect in the dock inself. Hundreds of posts with every Dell computer combination for 2 years. Call Pro Support they just keep sending refurbed defective docks that are not every put through testing. Come on Dell is it not time to fix this?

1785

2 Years and Dell has not fixed the "WD-19-TB USB internet dropping out of sleep mode defect."  Really gives you a lot of confidence in buying more computers from them. Every single solution from Dell users has not worked. The dock is defective.... fix it and replace it Dell instead of making customers waste hours and hours on a defective dock.

2 Bronze
2 Bronze
3219

Hi, I have the same problem with my Dell  Latitude 5510 and WD19.
I updated all drivers on dock and notebook finally doesn't work it

I changed to a different dock but it still didn't help. I also updated the bios in the computer. I have the same laptops and this problem does not occur. Updating windows didn't help either. However, I dealt with the USB problem - I installed an older version of the driver. Please help me find out how to handle this.
2 Bronze
2 Bronze
3006

This has been happening to our users as well. We have the Precisions 7540. Someone mentioned changing the PCI Express Link State to OFF and at first it seems like that worked. However it started happening again. What's odd, if I change the state to Maximum power savings and hit apply, then back to off, the network connection comes back again. This also appears to happen when the users were on WiFi connected to a VPN then they disconnect to plug into the dock. Pretty annoying issue.

2 Bronze
2 Bronze
2055

Just adding my two penance worth to this thread as we ourselves have been suffering all of the above with our WD19 and WD19s docks. We have about 60-70 in the field and they are causing a lot of wasted time / downtime. Seriously frustrating.

The main issues we experience are:

  • Ethernet connection dropout
    • We’ve noticed on a lot of our Latitude 3500/3590/5500/5510/5520 devices using a WD19/WD19s docking stations that the NIC on the dock isn’t being detected and therefore losing network connection completely. The user can still use Wi-Fi but this is undesirable. This problem isn’t consistent all of the time – there will be times whereby the NIC on the dock will be detected and other times it will drop out in front of you while in use. On one of our tests a latitude 5510 wouldn’t pic up the NIC from the docking station – but my XPS 13 recognised it straight away.
    • If we plug the ethernet cable in directly to the laptop, it is detected 100% every time.
  • External monitors not detected
    • On multiple occasions, we’ve had devices not detect external monitors when someone has come in in the morning. This can sometimes be resolved by only plugging 1 external monitor into the docking station at a time, but other times it doesn’t work at all. These are mostly Dell monitors in our organisation. All monitors have either HDMI and or DP interfaces and support a standard 1920 x 1080 resolution.
  • USB devices not recognised
    • We don’t particularly use many USB devices other than keyboard and mouse, but one user in particular uses a USB label printer – which periodically won’t connect when it’s in the dock and it will error saying the device isn’t recognised. On other users docks the USB ports will literally not register when a device is plugged in.
  • WD19 Power supplies
    • I was working on a latitude 3590 connected to a brand new WD19s dock a few days ago where the user came into work in the morning and the screens did not wake up. On further investigation and managing to get 1x of the screens working again Windows did complain that there was not enough power when I plugged in the second screen. Telling me the laptop now had insufficient power to charge. The dock has a 130w version power supply. The same as 99% of our other docks that were sold to us along with Latitude laptops.
  • Unknown USB Device (Device Descriptor Request Failed)
    • On regular occasions when starting up a latitude laptop or connecting a powered on laptop to a dock Windows will pop up a toast notification informing that the USB device is not recognised. On further investigation in the Windows Device manager under Universal Serial Bus controllers there is an ‘Unknown USB Device (Device Descriptor Request Failed)’ listed which would appear to be the dock itself. If you unplug the dock the alert goes away.

These issues were initially noticed on users that had Latitude 5510 devices – however, more recently users on other models are starting to experience these same issues as well. We run Dell Command on all of our devices here automatically pre scheduled on a monthly basis, so all of the drivers, BIOS and dock firmware is up-to-date.

Our Windows 10 installations are Microsoft Intune managed and also run the very latest 21H1 version of windows and are managed and kept up to date at all times.

Please for f**ks sake will Dell take this issue seriously and look at fixing it. The older WD15's we have been using for several years are still going and do not suffer from the mentioned issues. Or refund us the costs for the docks so i can go elsewhere for another vendors product.

2 Bronze
2 Bronze
3521

Add another "me too" to the mix.  What I don't get is, why would Dell still sell these?  Why do I, as an IT professional, have to find 33 pages of people with the same complaint about these, going back 2+ years, instead of Dell either fixing the problem or replacing the defective units with ones that are not?

Yes, I know it's because Dell likes money.  Doesn't make it right.  I'm supporting a city government that just bought a slew of new laptops with WD19S docking stations, and out of the box, they are defective.  There's no sugar coating this.  They do not work properly.  They are not fit for purpose.  And Dell must be laughing all the way to the bank, since there are few alternatives thanks to the chip shortage.  Ugh.

Latest Solutions
Top Contributor