Latitude

Last reply by 09-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
127678

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (393)
3554

This string was the only way I could prove that we weren't the only ones having issues with these docks. I came in when there were 'only' 23 pages and it was soon after the Dell closed the case "Because no one was commenting or replying."  So, basically, it's been me replying to everyone.

BTW, Dell has had to replace several of these because the nic just died. They are way under powered and Dell had them going into energy saving mode about 30 seconds after the last mouse or keyboard click. So, you may want to call them and get some of them replaced.

In all honesty, Dell's equipment isn't that bad. It's the people that you have to deal with to get things fixed that makes it a horrible experience. And, I'm not talking about the people you talk to on the phone when you call in a repair...it's the people above them that is the problem.

How are we solving our problem? We're going to Lenovo. At least you can work with them.

2276

Please see my response to GTBREA. It probably won't answer any of your questions, but it might give you some ideas.

3649

I have 2 docks and issues with Ethernet dropouts as you wrote. I tried all proposals I found.
One year of troubles. The only thing, that helped me were new Firmwares, Dell issued ...
When I applied them,  ethernet dropouts disappeared.

2 Bronze
2 Bronze
3707

Thanks RB78401. Ive had a look at your posts. Ive just tried the reg fix you suggested. Hibernation is tuned off for our Latitudes however the specific reg key hibernateEnabled was not present in the registry. 

Had a feeling it was potentially power related.

 

Thanks again ill update thread if makes any difference. Ive also looked at the Lenovos but they are seriously pricey! We have quite a lot of the WD19(s) so hoping a fix comes along at some point as this is causing a lot of headaches!  

Community Manager
3646

All users should have the following applicable drivers installed, then retest. If your laptop is not listed below, check your platform page to verify that the latest BIOS is installed.

Latitude 5400/5500 and Precision 3540 System BIOS 1.7.1

WD19 dock series firmware 01.00.25
(WD19/WD19S/WD19TB/WD19TBS/WD19DC/WD19DCS/WD22TB4)

Realtek USB GBE Ethernet Controller driver 1153.6.0418.2022 (TB16/WD15/DS1000/TB18DC/WD19/WD19TB/WD19DC)

 

 


Social Media Support

#IWork4Dell
Locate your Service Tag or Serial Number

3571

Chris,

It's nice that someone from Dell finally poked their head up after all this time, but (after more than four months and many, many back and forths with Dell's engineering team) my issue has been long since resolved. I've actually been assisting others because someone closed this thread out on Dell's end and no one was checking on it, besides me.

So please, read back a ways and help the people that the firmware update didn't resolve the issues.

RB

2 Bronze
2 Bronze
3313

Hello everyone; jumping in on this discussion. I'm troubleshooting this same issue; I'm on the latest versions of the laptop bios, Realtek USB GbE driver, and WD19 firmware. We have this issue affecting a variety of Latitude 74xx and Precision 75xx models, on WD19/WD19S docks. What I'm seeing is that whenever these machines enter modern standby (verified via "powercfg /sleepstudy"), applications lose the wired network connection connected through the dock. I'm aware past fixes in Dell's Realtek USB GbE driver purported to have solved this, but I'm still experiencing it with the latest driver 

<ADMIN NOTE: Broken link has been removed from this post by Dell>

I can workaround this by preventing machines from entering modern standby, but clearly the connected modern standby isn't working as intended. I've engaged Microsoft support (since my company has their premier support), and I'll see if we can make any determination on what's happening, but it's still very possible this is a Dell issue. 

2 Bronze
2 Bronze
3470

I've got a WD19TB that CONSTANTLY sends USB connection/disconnect notifications to any laptop plugged into it. Here's what worked for me:

Open Device Manager and look for 'Realtek USB GbE Family Controller' under the 'Network Adapters' list and right click to access Properties (It will be tricky because the Device Manager window will refresh every time it dis/reconnects. You have to be very fast to catch it!)

Click the Change Settings button (You may be prompted for Admin credentials)

Under the 'Power Management' tab you need to uncheck the box labeled 'Allow the computer to turn off this device to save power'. It can also help to disable the power saving features under the 'Advanced' tab, but that should do it.

I hope this helps someone!

2 Bronze
2 Bronze
4079

Hello everyone, IT Engineer for a 10K+ endpoint firm here. After a deep dive into this and engaging both Dell and Microsoft support, here are my findings. There are multiple things that need to be in place; which is part of the reason that so many different people are reporting different fixes. However, this is consistently solving issues my users are experiencing with their wired network connection while docked on a WD19.

  1. Laptop BIOS needs to be updated to the latest version for your model (my firm uses Latitude 7480 / 7490 / 7400 / 7410 / 7420 machines, but I can also recreate the issue on a Precision 3560 and Precision 7560)
  2. Docking station firmware needs to be updated to version 1.00.21.01
  3. Realtek USB GbE Family Controller needs to be updated to version 10.48.914.2021
  4. The driver needs to have the appropriate settings for modern standby / power management.

The setting for #4 depends on whether you are using modern standby or the legacy sleep states on your system / in your environment. Newer Dell machines and/or versions of Windows 10 don't support the legacy S3 sleep state by default.

If you're using the legacy sleep states, then @FriendoSupreme's answer above may solve your issue, but this didn't apply to my environment. 

If you're using the newer Modern Standby options, the "Power Management" tab will simply be missing from your driver properties. You can edit the same setting in the registry, but it will have no effect. I needed to go to the "Advanced" tab and enable "Modern Standby WoL Magic Packet". This is disabled by default in the latest version of the Realtek USB GbE driver, and the setting isn't even present in some older versions of the driver. 

I figured this out with help from this Microsoft documentation on networking power management with modern standby: "Windows assumes that the network devices that are integrated into a modern standby system are capable of protocol offloads and wake-on-LAN (WoL) patterns. If a network device does not have both of these capabilities, the network device is disabled during modern standby."

Sources:

3767

Great work! 

Latest Solutions
Top Contributor