Latitude

Last reply by 09-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
138170

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (393)
2353

Hi RoHe, 

I used Device Manager to roll back the driver.  Hope this works for you as well!

Eric

2 Bronze
2 Bronze
2337

Hi everyone,

After battling with this issue for months, I found a workaround. Dell Optimizer is the culprit in the situation and it must be completely removed from the computer. First uninstall "Dell Optimizer Service" via the Add or Remove programs in Windows and then uninstall "Dell Optimizer". I would suggest running a PowerShell script to make sure the service is completely removed as well. 

2 Bronze
2 Bronze
2262

2 Bronze
2 Bronze
1467

Been battling this same issue for a few days with a Precision 5560 on a USB-C hub monitor U2422HE. Finally discovered that the issue is some sort clash between the Realtek USB GBE family driver and a Dell wireless keyboard and mouse. Removing the USB dongle for the KB and mouse solved the problem. Plug it back in after a few minutes Dell Universal Receiver installs and then the ethernet starts dropping again.

Latest Solutions
Top Contributor