Latitude

Last reply by 09-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
138045

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (393)
7947

@HaikoS  thanks for your contribution to the thread.

For the multiple docking stations connected error message appearing, can you please try the following steps and let me know if it resolves the issue for you - 

Disconnect the docking station from the system and then boot it into the BIOS with the ac adaptor connected directly to the precision. (To access the BIOS, power on the system and keep tapping the F2 key in rapid succession.)

Navigate down to System logs and then BIOS events. There should be a listing of every time the message appears. Click on "Clear Log" and then apply and Exit.

Once done, connect up the docking station and see if the error message returns. If it does so, again disconnect the docking station and update the BIOS , even if it is to the same version

<ADMIN NOTE: Broken link has been removed from this post by Dell>

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

19956

Alan,

I was able to get the Link State Power Management option added through the link you provided and turned it to OFF on both options battery and plugged.  However, the problem still presents itself with the disappearing network connection.  Let me know if I should try something else.

Hoping for a fix soon.....Thanks!

17204

Hi Alan,

 

"Its currently affecting the following WD19 docking stations - WD19DC and WD19SC. I have had no reports of the TB version being affected." 



Allow me, then, to be the first to report that my WD19TB has this same ethernet dropping issue.



The dock NIC completely drops out (plays the USB disconnect sound) and immediately comes back online.



Using a Latitude 5490.  I had to update it to the latest bios as it wouldn't boot with the dock connected.  Got that fixed, updated all drivers... tried the PCI power management thingy mentioned, tried disabling green ethernet, EEE, and other various NIC settings, but it's a hardware drop from the NIC itself, as if I unplugged a USB NIC and reconnected it.  Note, it ALSO drops even with no ethernet cable connected to it.



I don't lose any other peripheral.  Monitors, keyboard, and mouse all stay working and power continues flowing.



I finally had to connect my ethernet to the port on the PC... getting frustrated, especially since my old E-Port replicator never had an issue..

17107

@Russael thanks for adding the information about the TB, I shall feed this back.

Additionally, thanks for this piece of information - "Note, it ALSO drops even with no ethernet cable connected to it."

That's quite interesting to know, no one else has provided this piece of info so far.

Thanks again for this info, I'll drop you a private message for some tag details.

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

16944

No problem.  The dock is personally owned, but the laptop is a corporate machine so certain troubleshooting steps may be limited.  I am able to update drivers and bios at least. 

 

Noticed it disconnecting as I had left my sound on while I had my ethernet jacked in to the laptop.  Saw the dock ethernet had bounced.

 

It has on a few occasions dropped a windows code 43 on it and wouldn't restart the dock NIC without unplugging the whole dock, power cycling it, and reconnecting everything.

16833

This fixed it for me.

Latest installer version: 2.45.2019.0618 ,A18 per important info on the driver download page it installs version Windows 10 - 10.33.0419.2019.

15342

Did anyone else have any luck with this driver? i noticed its the same version of driver as one that i had already tried but it looks like dell recently updated the package.xml in it (which i assume is a model support list). i doubt it fixes the issue (since the driver hasn't changed) but wanted to check with others. 

15333

It didn't with me.  Been running that specific Win10 driver and it continues to bounce.

2 Bronze
2 Bronze
7462

I had a problem with the connection of the actual cable that goes to the laptop and this is how I fixed it for the WD15:

on the docking station, the cable that goes to the laptop is actually a plug that plugs into the docking station. If I ever bumped it, it would disconnect everything and reconnect, sometimes missing the monitor function. 

if you look on the bottom of the docking station, there is a flap that reveals the mounting plate that holds the plug in place. If you remove the two screws, and flip the plate over so that it holds the plug in tighter this will solve this problem because there is an offset on the pegs that hold the plug in.. this fixed the problem I was having immediately! I could throw the thing a round and it would stay connected!

I hope this helps someone as I had a colleague with the same problem and fixed his too!!!!

9096

I found that if you go to the BIOS and change the Thunderbolt settings to 'No Security', it resolves the issue once the system boots up. Give that a try

Latest Solutions
Top Contributor