Latitude

Last reply by 09-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
137405

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (393)
7029

Hi All,

I have an incident opened with Dell about this issue and their last answer is that the Latitude 5400 is not fully compatible with Win10 Enterprise, only with Professional. I hope this is a bad joke but just to double check, what version of Win10 do you have installed?

7064

I'm having similar issues with network connectivity not working at all or very inconsistent with the WD19DC. Like many others this is happening on multiple 7450 w/ the wd19dc dock. We run Windows Professional so don't let them lead you down that ridiculous path that Enterprise isn't supported.

I'm asking for a refund on the docks that we currently have and testing startech.com docks.

 

7155

I already told them I'm not buying it but I asked for an official confirmation from the commercial. If, and that's a big if, he says the same, I'm gonna ask for a refund on laptops and docks...

7170

I didn't ready through all the pages on this topic, so if this is a repeat solution, sorry., 

The only luck that I've had with some of the laptops using this dock was turning off both battery and plugged in "Link State Power Management" in the advanced settings in battery options. 

Other than that the dock just <Profanity removed> and was pushed to market way to quick probably trying to trying to recover from all the issues of the previous single port docks. Everything after the E port dock has come with problems that haunt IT depts.

7223

same issue with WD19 usb-c dock. Random network and USB crashes. Especially bad due to filesystem crashes. Issue started _with_ linux kernel 5.3.7 and newer. Before this kernel version, no problems with the WD19 usb-c dock. Hopefully there is a fix, otherwise this device is useless. Its too risky to attach USB drives to the dock until the problem is fixed.
2 Bronze
2 Bronze
6739

I also am having this issue, would love to hear a solution!

6267

Last I heard is that Dell's engineers are testing a solution, but is not ready for release yet.  I hope it comes soon, and it fixes the problems, and doesn't introduce new ones. 

2 Bronze
2 Bronze
6227

I am experiencing the same issue as I deploy a large order of Latitude 5400/WD19s.  I've temporarily put a hold on deploying hoping a fix will be released soon.

2 Bronze
2 Bronze
5826

any idea if this "fix" is also in the bios update for 54XX? quote from 7X40 1.5.1 bios: - Fixed the issue where the Ethernet disconnects when the system is connected to a dock. Has anyone tested the dec 2019 bios version, if this fixes the dock problems?
5789

I had similar issues with XPS and Vostro laptops and  the WD19. The ethernet connection dropped when I locked windows (windows key + L) and left the computer alone.

This solution worked for me:

Download the latest Realtek-Ethernet driver (updated December 21st, 2019) and install it. (Link: https://www.dell.com/support/home/uk/en/ukbsdt1/product-support/product/dell-wd19-130w-dock/drivers) Go to device manager, choose network adaptors and select "realtek usb gbe family controller" -> Properties -> Advanced and deactivate "Green Ethernet".

Latest Solutions
Top Contributor