Latitude

Last reply by 08-04-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
116563

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (383)
2 Bronze
2 Bronze
7072

We purchased three 7740's and the WD19 dock station.  The dock is pure garbage.  Blue screens, lock ups, USB ports disconnecting, and the Ethernet port dropping out.  Once we took the dock out of the equation the laptops are solid.

 

Maybe in another 3 months Dell will figure out what the hell is going on and fix these.  We had similar problems with the 7710's and the dock.  After about 6 months they were solid after many firmware and bios updates.

 

How Dell lets something like this happen over and over with their new products floors me.  Especially when you pay 7k for a laptop.

10184

Windows 10 solution for network stop working (it worked for me):

Device manager -> Network adapters -> Realtek USB GbE Family Controller -> Properties -> Advanced

Disable 3 items (sorry but I can only write it in portuguese as my windows is in... portuguese eheheh):

1) Ethernet de consumo de energia eficiente

2) Ethernet verde

3) Idle power saving

In case you don't have these options, you must first install latest drivers with WD19 dock connected.

10275

The couple of PC's I manually manually unticked 'stop devices when my screen is off to help save battery power'. Still disconnect from network when locked.

I have also logged into device manager and where the power management setting is available on USB and Network card, i have unticked 'Allow the computer to turn off this device to save power'. Again the laptop is disconnecting from the network when the screen is locked. This cause their programs to crash.

I've also tried some of the registry changes to show additional sleep timings in power management. Again these haven't helped.

We are using Latitudes 5500 laptops with the Dell WD19 dock. Windows 10 Enterprise 1803. All drivers and BIOS are up to date, including the Realtek  drivers for the dock. The network connection is via ethernet cable.

Are there any other suggestions to try?

10779

Did you manage to find a Group Policy Setting? I also rather not change every laptops setting manually.

Cheers

8499

I found that if you go to the BIOS and change the Thunderbolt settings to 'No Security', it resolves the issue once the system boots up. Give that a try

2 Bronze
2 Bronze
6865

I had a problem with the connection of the actual cable that goes to the laptop and this is how I fixed it for the WD15:

on the docking station, the cable that goes to the laptop is actually a plug that plugs into the docking station. If I ever bumped it, it would disconnect everything and reconnect, sometimes missing the monitor function. 

if you look on the bottom of the docking station, there is a flap that reveals the mounting plate that holds the plug in place. If you remove the two screws, and flip the plate over so that it holds the plug in tighter this will solve this problem because there is an offset on the pegs that hold the plug in.. this fixed the problem I was having immediately! I could throw the thing a round and it would stay connected!

I hope this helps someone as I had a colleague with the same problem and fixed his too!!!!

14737

It didn't with me.  Been running that specific Win10 driver and it continues to bounce.

14746

Did anyone else have any luck with this driver? i noticed its the same version of driver as one that i had already tried but it looks like dell recently updated the package.xml in it (which i assume is a model support list). i doubt it fixes the issue (since the driver hasn't changed) but wanted to check with others. 

16237

This fixed it for me.

Latest installer version: 2.45.2019.0618 ,A18 per important info on the driver download page it installs version Windows 10 - 10.33.0419.2019.

16348

No problem.  The dock is personally owned, but the laptop is a corporate machine so certain troubleshooting steps may be limited.  I am able to update drivers and bios at least. 

 

Noticed it disconnecting as I had left my sound on while I had my ethernet jacked in to the laptop.  Saw the dock ethernet had bounced.

 

It has on a few occasions dropped a windows code 43 on it and wouldn't restart the dock NIC without unplugging the whole dock, power cycling it, and reconnecting everything.

Latest Solutions
Top Contributor