Last reply by 01-25-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Windows 11 & issues with network connection on a dock

Checking to see if anyone else has seen this problem.  Latitude 5520 on a docking station, running Windows 11.  The network connection keeps flaking out.  I'll have the ethernet connection symbol, then it will go to Wi-Fi then it goes to the World (disconnected) symbol. 

Here's the thing, my network connection is still working.  I can still chat on Teams, still get to websites, still receive email.  But it blips in and out while I have the world symbol.

I've rebuilt my machine, I've updated firmware on everything including the dock.  I'm on a different computer entirely with a fresh build, even tried a different docking station and it still happens.

At this point, I don't know if it's a Windows 11 bug or a Dell driver issue, but it's beyond annoying.

For now, I've unplugged the ethernet port of the dock so I can keep going without interruption, but would love to get this fixed permanently.  

Anyone else see this?

Replies (56)

Same issue as described, also did the same with regards to connecting ethernet right to the laptop and avoiding the docking station as a work-around.  Meh, this wd19 docking station, idk, about a year in with it and some head-scratchers for sure (led flashing, actual plug casing (plastic on the usb-c end) separated day 1, and yep, odd ethernet drops with Win11 -> simple unplug-replug of usb-c connection to resolve).  Here is flow control post from recent days Dell shared with me from another post.  So far,,, only been a few days, but so far, since enabling flow control, have not had other drops with ethernet via docking station...


So with this new computer/rebuild/dock, I looked, my flow control is enabled but it still has been dropping the connections. Maybe it will help the others though, so thanks!

2 Bronze
2 Bronze

Hi all,

I am experience the same issue with my Dell XPS 9320 with Windows 11 Ent. and no ethernet on WD22TB4 Docking Station.

I already tried:
- Windows update
- BIOS update
- SupportAssist to driver update
- Manually installed latest Docking Station driver
- Checked Flow Control is enabled

Bonus info:
We got the exact same issue on some Lenovo T480, T490, T14 etc.
After upgrading from Windows 10 to 11 our users have the same issue with no internet on their Lenovo Thunderbolt 4 and USB-C Docing stations.

From my experince, this could be something related to a Windows 11 bug, chipset or driver issue.

A wakeup call for Dell and Lenovo; We need a solution now!


We also encounter this with every latitude we have upgraded to windows 11 and is using WD
19 docking station.

The only exception is one single latitude 7430 which for some reason does not suffer from this issue.

Only difference is it is slightly newer than the rest (12th gen cpu and not 11th like the rest). Not sure what makes the difference.

2 Bronze
2 Bronze

We have this issue with Latitudes on Windows 11 as well. We connect to Dell USB-C docking monitors and Ethernet is plugged into the monitor.

It is most noticeable in video conferencing like Teams, Zoom, Webex. 


Only fix I've had so far is to leave the ethernet cord unplugged and use WiFi.

2 Bronze
2 Bronze

I am having this exact issue with only 1 machine and have 22 exact setups some running Win 11 and some still on Win 10. I was able to resolve for a short time by uninstalling USB Ethernet and deleting driver and re-scanning and letting Windows reinstall. No reboot and it started working for a few hours then switched back to wifi when it failed and now will not connect after disable re-enable. I have deleted this time as I want to find a real fix. I replaced the Dock with a spare and had the same issue. Disconnecting Dock and reconnecting from machine didn't resolve. 

2 Bronze
2 Bronze

I discovered this after a bit of digging. I was running the latest version of Driver for the USB G Ethernet however I ran the driver updater. Realtek-USB-GBE-Ethernet-Controller-Driver_3K7FF_WIN_1153.6.0418.2022_A27_01

During the install process I noticed that on the removal of the previous driver that it connected to my network then as it began installing drivers it went right back to no connection. After it completed it was not connected as it was before. I then went to the driver and rolled it back to previous and it immediately connected. So the latest driver breaks the Dock's Ethernet. 

2 Jasper
2 Jasper

Did you try

Network adapters -> Realtek USB gbit ethernet controller -> Properties -> "Configure" -> "Advanced" -> Idle Power Saving > Disable.


2 Bronze
2 Bronze

Hello together, 

Today i had contact with the Dell Support. 

They told me all XX20 Systems have the same issue with windows 11.  Dell knows it is a USB GBE Driver issue.

"Intel is already working on a version of the USB GBE driver optimized for Windows 11. However, a definitive release date for this has not yet been set."

Latest Solutions
Top Contributor