Last reply by 01-25-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Windows 11 & issues with network connection on a dock

Checking to see if anyone else has seen this problem.  Latitude 5520 on a docking station, running Windows 11.  The network connection keeps flaking out.  I'll have the ethernet connection symbol, then it will go to Wi-Fi then it goes to the World (disconnected) symbol. 

Here's the thing, my network connection is still working.  I can still chat on Teams, still get to websites, still receive email.  But it blips in and out while I have the world symbol.

I've rebuilt my machine, I've updated firmware on everything including the dock.  I'm on a different computer entirely with a fresh build, even tried a different docking station and it still happens.

At this point, I don't know if it's a Windows 11 bug or a Dell driver issue, but it's beyond annoying.

For now, I've unplugged the ethernet port of the dock so I can keep going without interruption, but would love to get this fixed permanently.  

Anyone else see this?

Replies (56)

Does changing the adapter setting for Priority & vlan help when vlan is disabled or enabled?  Also, you still disabling the power management, energy efficient, magic pack WOL?


I've messed with many of those settings over time and it had no effect on the situation. If you read the thread, some others tried some things that seemed to work for a bit, but not overall.  My only fix so far is not to use the ethernet jack on the dock.

2 Bronze
2 Bronze

Dear Community,


before throwing Windows 11 out of the window please make sure you have installed a driver version 10.x for the Realtek NIC in order to get the LAN jack of the docking solution up and running. As long as the newest 11.x driver does not function properly I found the 10.x version of the driver running smoothly. Please also refer to my posts from 2022-10-26 and 2022-10-27.




Unfortunately, the 10.x driver did not work for me.


I experienced this and other odd behavior with slightly different Latitude models. I found those models to be difficult that were originally shipped with Windows 10 and upgraded to Windows 11. Although my statistical basis contains only one (1) device I didn't come across this misbehavior when creating a fresh installation with Windows 11.


Maybe you try installing one exemplary device with Windows 11 while keeping an eye on the driver version and see whether that makes a difference or not!? Additionally make sure that all other software components have been updated via Dell Command Update.


Best regards!


When my Realtek USB from DELL Dock work, i open powershell in admin mode and use that:

dism /online /get-drivers /format:table | findstr Realtek | findstr /c:"| Net" | ForEach-Object { ([string]$_).Split("|")[0] } | ForEach-Object { echo "pnputil -d $_" } | cmd

After all drivers Network Realtek pnp drivers are remove from windows only used one are alive!
2 Bronze
2 Bronze

Hello all.. I think I've found the solution and here it is:

In the Realtek card setting you have to disable ALL of the following parameters:

-    Adaptive Link Speed -> Disable
-    Battery Mode Link Speed -> Non rallentamento
-    Flow Control -> Disable (This seems to be the principal problem!) <<--------
-    Energy efficient Ethernet -> Disable
-    Idle Power Saving -> Disable
-    Wake on Magic Packet -> Disable
-    Recv Segment Coalescing (IPv4) -> Disable
-    Recv Segment Coalescing (IPv6) -> Disable
-    Shutdown Wake-On-Lan -> Disable
-    Wake on link change
 -> Disable
-    Wake on Pattern Match -> Disable
-    WOL & Shutdown velocità collegamento -> Non rallentamento

Latest Solutions
Top Contributor