Last reply by 01-25-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Windows 11 & issues with network connection on a dock

Checking to see if anyone else has seen this problem.  Latitude 5520 on a docking station, running Windows 11.  The network connection keeps flaking out.  I'll have the ethernet connection symbol, then it will go to Wi-Fi then it goes to the World (disconnected) symbol. 

Here's the thing, my network connection is still working.  I can still chat on Teams, still get to websites, still receive email.  But it blips in and out while I have the world symbol.

I've rebuilt my machine, I've updated firmware on everything including the dock.  I'm on a different computer entirely with a fresh build, even tried a different docking station and it still happens.

At this point, I don't know if it's a Windows 11 bug or a Dell driver issue, but it's beyond annoying.

For now, I've unplugged the ethernet port of the dock so I can keep going without interruption, but would love to get this fixed permanently.  

Anyone else see this?

Replies (56)

Bios of the Dock or the laptop - what bios version?


BIOS from Laptop. For latitude 3520 we tried 1.21.0 and windows 11 22h2 without having any Network issues for now 6hours. 


I have see the issue on all the latest BIOSs. This includes our 5420s with 1.21.0 and 1.22.0 that was just released two days ago. It only happens every few days for us so it is hard to say that it is stable after only 6 hours. 

We have narrowed the issue down to any Windows 11 22h2 computers connected to the Docks or monitors using a Realtek USB GBE Ethernet Controller Driver. For that reason I don't suspect a computer's BIOS firmware would be the ultimate fix. Dell did just release a new Realtek USB GBE Ethernet Controller Driver today. 1153.9.x. I am trying that on one test computer and leaving the second test computer alone. Like I mentioned the issue doesn't happen every day so It might be a few days before we know if it has helped.

WD19S docks:

Monitors with Ethernet:

They are listed differently on Dells support but I suspect they are the same driver.



I just tried the updated drivers/BIOS...minutes later, I've got the world symbol again.


After update, tried various versions of enabling/disabling, the Wake on Magic Packet, Energy-Efficient Ethernet, Green Ethernet in the Realtek USB GbE Family Controller, none of it worked. If I messed with a setting, I'd get my ethernet signal back for a few minutes, then back to the World Symbol and network trouble again. I just unplugged the Ethernet cord again, back to WiFi.


Can I ask what type of network you are on? Home , enterprise, other? I am trying to determine if this Realtek controller doesn't play well with Windows 11 22H2 or our Enterprise network or Both.

I guess the test would be to see if the issue happens if you change networks. It only shows it self one ever few days so It is hard for us to test these various fixes.


Work/Enterprise network. Though, when I work from home (I have a dock set up there as well) I still get the same problems if I try to use an ethernet connection. My only resolution so far has been to leave the ethernet connection unplugged on the dock and just stick with WiFi.

I'd hold off using Windows 11 in an enterprise situation until they resolve the problem. Or buy something that isn't a Dell.

2 Bronze
2 Bronze

Here's an other variant of the problem:


- Dell Latitude 5430 (BIOS 1.7.0)

- Dell Docking Solution WD19S (latest driver for Realtek GBE Family Adapter according to "Command Update")

- Windows 11 22H2 wit all the latest updates


Symptom: LAN cable attached to notebook directly works seamlessly. LAN cable attached to docking solution does not work at all. Electric connectivity seems to be OK by looking at the blinking LEDs but Windows says that there is no cable attached.


Tried various solutions to no avail ... if we want to have a cable connection we need to attach the cable to the notebook directly. That is really annoying since docking solutions are meant to reduce (un)plugging of cables.


Thank you in advance for addressing this quickly


Thanks for the tip about plugging the ethernet cord in you said, it works, but isn't optimal. Haven't seen a fix from Dell for this yet.

2 Bronze
2 Bronze


After doing some research and the good old "trial and error" method I have a feasible solution at hand that might work at least for some of you.
Problem: LAN jack of docking station does not work at all under the following setup:
- Dell Latitude 430
- Dell Docking Solution WD19S
- Windows 11 Pro 22H2
- Realtek USB Ethernet Controller All-In-One Windows Driver version 1153.9.0823.2022
To make a long story short: Uninstall the "Realtek USB Ethernet Controller All-In-One Windows Driver" via "Add Programs/Features" and (just to make sure) reboot your machine. The LAN jack of the docking station should now work properly.
For all of you who would like some more details here's what I did (please read information until end of file before following the instructions):
01. Uninstall "Realtek USB Ethernet Controller All-In-One Windows Driver" via "Add Programs/Features".
Result => OK (The uninstalled driver version was 1153.9.0823.2022
02. Uninstall the corresponding network adapter (Realtek USB GbE Family Controller) via device manager.
Result => OK
03. Rebooting the machine.
Result => OK
04. Check if "Realtek USB GbE Family Controller" reappeared in device manager.
Result => OK
05. Check driver version of "Realtek USB GbE Family Controller" in device manager.
Result => OK (Windows uses the internal driver version
06. Plugging in LAN cable in LAN jack of the docking solution.
Result => OK (network interface card (NIC) gets an IP address and routing works as expected)
07. Flipping LAN cable from LAN jack of the docking solution to internal LAN jack.
Result => OK (NIC gets an IP address and routing works as expected)
08. Unplugging/Flipping LAN cable back and forth between internal and docking solution LAN jack.
Result => OK (Works as expected)
09. Reinstalling latest Realtek device driver software from (Install_USB_Win11_11.8.0608.2022_20_08232022.exe)
Result => OK (At first sight nothing out of the ordinary after setup finishes)
a) After a brief moment the "world symbol" appears in the system tray.
b) Unplugging LAN cable and pluging in again gives the expected symbol that indicates that you are on a wired connection.
c) The NIC gets an IP adress but no connection - LAN or WAN - is possible. Even the connected WiFi is not operational even though it should work.
d) Switching LAN cable to internal jack works perfectly.
10. Uninstall "Realtek USB Ethernet Controller All-In-One Windows Driver" via "Add Programs/Features" AGAIN or see step 01 respectively.
Result => OK
11. Go to device manager and check if the internal driver version is now back to or something similar according to step 05.
Result => OK (Windows uses the internal driver version
12. Plug in LAN cable to LAN jack of the docking solution
Result => OK (Works as expected)
Resolution: Follow all the steps including 08 and see if everything works fine. DO NOT (re)install Realtek device driver software version 11.x.
What I did not do: Try installation of Realtek device driver software version 10.x - I just relied on the internal Windows driver version.
Pay attention to not update the Realtek device driver software via "Dell Command Update" accidentally.
Keep in mind that all this happened on a Latitude 5430 with docking solution WD19S on Windows 11 Pro 22H2. We also have the same combination but with Latitude 5530 where these symptoms DO NOT appear.
Hope this was helpful at least to one of you
Latest Solutions
Top Contributor