Andrew James
1 Copper

e6520 with Windows 10 can't detect nvs 4200m video card

I have a Latitude E6520 with the NVS 4200M video card combined with the Intel video card. Since doing a clean install to Windows 10, 64-bit, the NVS 4200M is not detected and I cannot run higher level graphics features like OpenGL. This did operate in Windows 7. I have tried installing NVIDIA drivers as appropriate, but they cannot detect the hardware. Is there a work around to get the system to detect the additional video card on this laptop? Thanks!
Labels (1)
0 Kudos
4 Replies
nyc10036
3 Zinc

Re: e6520 with Windows 10 can't detect nvs 4200m video card

Did you bother installing chipset driver?
0 Kudos
Mary G
5 Iridium

Re: e6520 with Windows 10 can't detect nvs 4200m video card

You cannot install Nvidia drivers from Nvidia. Laptop drivers must come from Dell because they are customized for your exact model. However--Your old model is not approved by Dell for upgrading to 10 (no windows 10 dell drivers available) so you must use windows 10 generic drivers. Use Device Manager and allow windows to search for a driver for Nvidia card. 

0 Kudos
Andrew James
1 Copper

Re: e6520 with Windows 10 can't detect nvs 4200m video card

I've done every upgrade possible on the machine through Dell and followed the Dell tutorial on migrating this machine to Windows 10 (some of the drivers need to be downloaded as "Windows 8" and installed that way).


@nyc10036 wrote:
Did you bother installing chipset driver?

 

0 Kudos
Andrew James
1 Copper

Re: e6520 with Windows 10 can't detect nvs 4200m video card


@Mary G wrote:

You cannot install Nvidia drivers from Nvidia. Laptop drivers must come from Dell because they are customized for your exact model. However--Your old model is not approved by Dell for upgrading to 10 (no windows 10 dell drivers available) so you must use windows 10 generic drivers. Use Device Manager and allow windows to search for a driver for Nvidia card. 


The issue is that the device does not show up in my device manager.  I think the BIOS do not recognize that it exists. I went through the BIOS and saw no settings to select which video card I would prefer. 

0 Kudos