Highlighted
Durango2k14
1 Copper

Bluetooth adapter issues in XPS 13 developer edition (Ubuntu)

Hello,

I just got the new Dell XPS13 developer laptop and I enjoy every aspect except the bluetooth functionality.

At first bluetooth seems to work fine and the adapter is detected within blueman bt manager.

However if I leave to go do something and come back I notice that the bluetooth no longer works and not only that the adapter is no longer detected.  I try restarting bluetooth service but no luck.

I have to do a shutdown/power up for things to work again.

Here is a screenshot of the bluez bt manager


As you can seen everything is grayed out, due to adapter not being detected.

I have looked at other posts but it's not that bt is not detected but that it eventually it stops working.

Anyone have any insight in this? Does a newer version of Ubuntu take care of this problem?

I really would like to handle this since I work a lot better with a mouse device.

If you need further info from my machine please let me know and I'll provide.

Thanks for any help.

Tags (3)
0 Kudos
2 Replies
katycorp
1 Copper

RE: Bluetooth adapter issues in XPS 13 developer edition (Ubuntu)

I am having the exact same issue. Bluetooth was working great until it started saying it was disable. Then I ran some updates and rebooted and now it says it can't detect it at all. 

0 Kudos
katycorp
1 Copper

RE: Bluetooth adapter issues in XPS 13 developer edition (Ubuntu)

Actually I might have figured out a fix. It looks like FN + F2 toggles the wireless and bluetooth radios at the same time. I think disabling/re-enabling my wireless in the toolbar caused the bluetooth to also be disabled. By hitting FN+F2 twice, I was able to turn off the wireless, and then turn both the wireless and bluetooth back on. 

Seems like a weird mapping of the hardware/keyboard switch that isn't very robust.

0 Kudos