Linux Developer Systems

2 Bronze

Crippled audio with "Apple type jack" on Linux

Hello there,


I got the XPS developer edition with ubuntu pre-installed but I quickly switched to fedora 23. Anyway, I noticed that the audio jack was not working properly because I plugged my headphones and while I could hear the music coming out it sounded like it was only playing on one channel. I have a fairly new pair of MEE Electronics headset which is a combo of headphones and mic.

At first I thought that probably the headphones had issues, I plugged my other pair of earphones and got the same result. After checking that both the headphones and earphones were working by plugging them to other devices and getting output just fine I started to think that the problem was in fact the computer so I started to check and realized that maybe it was the jack. Luckily I have a different cable which turns out to be just audio (no mic) and swapped it on the headphones and now the audio works just fine on the laptop.

Then doing some research found that this type of connector is known as "Apple like" at least by looking at this diagram:

So looking at the two at the far right I either have a nokia or apple type connector (the ones with 4 sections) and using that type of cable/connector does not work properly with the laptop, however using one with 3 sections like the ones on the left do work.

So my question would be: Doesn't this laptop support a headphone/mic combo in its jack, or could it be an OS related issue? Again, I'm using fedora 23 (which has a kernel 4.2) and judging by the myriad of posts about audio issues on Linux it would not be a surprise that the problem is Linux itself, not the jack.

Anybody experiencing the same?

Replies (2)
3 Silver

Hi - I have a 2014 XPS 13, recently upgraded to Ubuntu 15.10 (see other post).  I have used all kinds of stereo headphones, mostly with mic on the the XPS 13 and my  android phone.  No problems with either one on any OS version.

I don't know what the pinout is on the connector, but it works with Android.

So, unless you have gotten some really weird headphones, it should work either with or without the mic.

Alan

2 Bronze

Thanks for the reply...


Turns out that Fedora 23 specifically has issues with the Audio/Wireless combination. I read yesterday several threads on bugzilla/lkml etc. so I'm not alone.

I tried ubuntu today from a live usb, audio worked fine, the mic and headphones were activated when plugged in with the 4 section conector.

So I'm guessing I'll have to wait until I get kernel 4.3 to see if that fixes it, weird thing is that ubuntu 15.04 has the same kernel version as Fedora 23.

Hardware-wise, the xps 13, 2015 is a nice machine, sadly it was branded as a linux compatible laptop yet I'm having more issues than with older laptops that were not officially supported.

Top Contributor
Latest Solutions