Linux Developer Systems

Start a Discussion
3 Silver

Dell DA200

Hi all,

just so you know, I have given up on Dell's DA200....I don't see it working any time soon, although I have forwarded them patches and resolved bug reports from the Linux community. It's just pathetic and ignorant that Dell refuses to integrate this, so that their customers could actually benefit from it.

I received this message from one of the Dell employees more than a month ago
"Regarding DA200. Our scope of support for Ubuntu doesn't include DA200. However, I do know that high level Dell people are talking about it and there may be more support for that in the future. No ETA at this time."

Therefore I decided to move on and regret having wasted 70 euros on a worthless piece of garbage. It's beyond me how Dell refuses to support one of their very own products.... especially considering that this Laptop (Dell XPS 13) doesn't leave much room for other choices, since there is no native HDMI, Displayport, or Ethernet port... thus people are relying on *working* adapters, unfortunately not everything is wireless yet.

Anyway, I will think twice before I will buy another Dell product..... just so you know, I will continue to post this "rant" on my blog and as an Amazon review to save others from making the same mistake.....

maybe this will make Dell wake up.....

Replies (15)
3 Silver

I have the 2014 XPS 13 (model 9333) and can connect to 2+ external displays (regular HD) using the Dell D3100 external dock.  You may wish to review my posts from Oct 2015 in case something there can be of help. I had to upgrade to Ubuntu 15.10 (now on 16.04) & install the newest drivers for the D3100 video chip, but after that everything worked quite well.


2 Bronze
2 Bronze

Along the lines of what Cloojure mentioned, sometimes updates can help.

I was on 16.04 LTS, and enabling the HWE or HWE-Edge stacks helped with hardware issues since the HWE uses the 4.8 kernel and HWE-Edge uses the 4.10 vs the 4.4 kernel with default 16.04 LTS:

As per that wiki, run the following for HWE and the 4.8 kernel:

sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

or for HWE-Edge and the 4.10 kernel:

sudo apt-get install --install-recommends linux-generic-hwe-16.04-edge xserver-xorg-hwe-16.04

Note:  The xserver-xorg package does not have an HWE-Edge equivalent.

2 Bronze
2 Bronze

I'm currently on 17.04 with the 4.10 kernel.  I will not say the DA200 works perfectly.  I've seen weird things especially with the display ports and some external monitors, but it generally works without issue at this point for my setup.

2 Bronze
2 Bronze

I also have a DA200 and I connect it to my xps13 9350 running Ubuntu. For some time everything was working except HDMI port. Recently I noticed that the problem of HDMI is related to the output resolution. For some reason the default resolution of HDMI output was something which couldn't be handled by the port. I tried different resolutions to find the optimum one and I can confirm that now everything (USB3, LAN, VGA and HDMI) with kernel 4.11 works smoothly.

2 Bronze
2 Bronze

The output resolution is indeed limited on the DA200; you cannot connect a 4K monitor via HDMI for example with this adapter.

"Regular" HDMI was working for me, but ceased to work a while back. I am now on kernel 4.10.13 and I cannot output anything to HDMI anymore. Therefore, I was impacted by a regression of some sort, but what and when...

2 Bronze
2 Bronze

Hi guys,

there is a bug in the i915 module which have been fixed but unfortunately the fix has not been included in the kernel 4.8.

Here is a procedure to fix the issue for HDMI display:

sudo -i

apt-get install linux-source-4.8.0

cd /usr/src

tar -jxf linux-source-4.8.0.tar.bz2

cp -R ./linux-source-4.8.0/ubuntu/i915 ./i915-usbc

cd i915-usbc

cat << EOF > dkms.conf








sed -i 's#../../../platform/x86/intel_ips.h#../../linux-source-4.8.0/drivers/platform/x86/intel_ips.h#g' intel_pm.c

wget -O /tmp/drm-i915.patch

patch -p5 < /tmp/drm-i915.patch

dkms add -m i915 -v usbc

dkms build -m i915 -v usbc

dkms install -m i915 -v usbc


It creates a module for usbc and build it from the source patched.

Unfortunately, if you upgrade your kernel, you will have to do it again.



I've plugged my DA200 adapter in my newly purchased XPS 9370 dev edition and tested only the ethernet port. It works for a bit and then it flaps, so it's not usable. It constantly goes up and down.

I have been using the DA200 on the XPS 9370 (Ubuntu 18.04, fresh install) for about a month without problems (confirmed DisplayPort, VGA and USB).

This morning there was a firmware update for Thunderbolt (if I remember correctly it went from version 27 to 33??) which failed to complete. Afterwards, USB's from the DA200 stopped working, I have only verified that the DisplayPort works fine.


Everything updated but still Ethernet port goes down and up. Is there a fix planned?

Top Contributor
Latest Solutions