Linux Developer Systems

Start a Discussion
2 Bronze
2 Bronze

Dell XPS 13 9350 + Linux + Thunderbolt 3/USB-C

Hi all. I've been following these forums for a few weeks hoping to find a solid solution to my problem. Through my searching and browsing, it seems like there are numerous people mentioning the same or similar issue, but so far I can't seem to find any concrete solutions or knowledge from the community or from Dell. I'm hoping this post is more on-topic and provides more detail for the issue so we can better diagnose it and find a solution.

First though, the issue. I'm running the 2016 Dell XPS 13 9350 with an external Dell 4K monitor (P2415Q) using the USB-C/Thunderbolt 3 output with an adapter to mDP. I'm running Ubuntu 16.04 with 1.4.4 BIOS, and 4.7 mainline kernel. All drivers were updated as of two weeks ago prior to wiping Windows and installing Linux.

The external is recognized (i.e., it shows up in both xrandr and in Display settings) but the picture never remains. It will appear briefly, maybe for a few seconds or so, but then the screen goes black. I'll add that the external doesn't turn off (or go to sleep), but it doesn't display anything and is still shown in settings.

I've read that this could be related to ACPI power modes, namely RC6 with Skylake processors. I've tried appending a line to my kernel to disable RC6 entirely, but that doesn't seem to work. Along these lines, I've also read that this does fix some instances and this patch will be included in the 4.8 mainline kernel update (it's in RC2 right now, so soon?).

Admittedly the adapter I'm using is a $20 "cheapo" from Amazon, though the vendor does say it supports 4K at 60Hz (but I guess vendors can say whatever they want). I've been hearing positive things about Google's adapter, but don't want to shell out the $40 until I've narrowed the problem to the adapter. From the numerous other posts from folks using various adapters all whom are experiencing the same issues, I'm led to believe the adapter isn't the culprit.

I've also read that there could be some conflict with the wireless adapter, and that reducing its power stabilizes things. Unfortunately, reducing the power of my wireless adapter does not fix the issue, and even if it did, it is a suboptimal solution as it slows my connection considerably.

Some questions I'm hoping to get answers for are:

* is this a known issue and are my experiences on par with others, or are things slightly different?
* does Dell know about this issue, and are they working on a solution? I'm totally OK waiting for a solution, it'd just be nice to know one was being actively worked on
* is there a problem with the hardware? Is this Dells problem and I should return my device?
* is there some hidden driver update out there that fixes this issue (that's for Linux, not Windows)?
* has anyone found a temporary solution that does work?

I would like to scope this conversation to linux operating systems using external displays via the USB-C/Thunderbolt 3 connector, to hopefully keep it on-topic.

Thank you all in advance. I hope this thread proves useful to many.

Replies (37)
3 Silver

The very recent changes in 4.9 really help multi monitor stability. How do you force wireless only to use the higher Hz signal? I remove wireless drivers before suspending.
2 Bronze
2 Bronze

I had to make the adjustments on my router.

2 Bronze
2 Bronze

It works fine for me with:

Computer: XPS 13 9360

OS: Ubuntu 16.04

Cable: Google (https://store.google.com/product/usb_type_c_to_displayport_cable

2 Bronze
2 Bronze

I just bought a brand new Dell XPS 9360 with Ubuntu 16.04 preinstalled. Right out of the box, the adapter doesn't work for HDMI. You can tell the display is struggling. It flickers and moves windows around as if I'm connecting and disconnecting an external display, but never successfully connects. There is never any image on the external monitor. I had to connect using a VGA cable, which is a workaround but I'm wondering why the HDMI doesn't work out of the box?

Under System Settings -> Displays, I can see the Goldstar monitor appearing and disappearing again.

I notice under http://www.dell.com/en-us/shop/accessories/apd/470-abqn?ref=192_recs_img that the reviews for this adapter aren't stellar.

2 Bronze
2 Bronze

At this point, I think there is *plenty* of evidence that something is really wrong. This other post [1] uses the same cable that is mentioned two posts above but on a 9350, not 9360 as in that post, and has the same issues most of us have reported for the 9350. So, neither the DA200 nor the Google cable seem to work with the 9350. In the case of the last post (9360), the DA200 doesn't seem to work either. So, when are we hearing from Dell? 

[1] en.community.dell.com/.../19997980

2 Bronze
2 Bronze

I've been using the 9350 for a few months with external monitors and Ubuntu 16.10.   I was coming from a Macbook retina 12 inch, so I've been using the "Apple USB-C Digital AV Multiport Adapter".  It worked on 16.04 as well as 16.10, but it is a bit flaky, and sometimes I need to reboot to detect an external display.

I just got my first DA200 in the mail and was surprised to learn that "adapter from Dell + developer laptop from Dell = doesn't work". WOW!  And they don't respond in this thread either... that's too bad because I saw various posts by folks from the project Sputnik people on github.  Yes, real humans!  Developers!

Anyway, I actually got dual booting with W10 working, so I've done all the updates recommended by "Dell Command | Update", but I still see the same behavior described by @personwithcomputer -- it detects a monitor, flickers, but nothing appears on the external screen via HDMI under Linux.  In W10 the DA200 works just fine.

2 Bronze
2 Bronze

I solved the problem as follows, I hope it helps someone. First I updated the Thunderbolt driver as written here. From version 16 to the latest - 26.1. While reading this thread, I noticed that by disconnecting the network, the monitor is working correctly. Then I limited the power of the Wi-Fi from 31 to 15. To do this, you just need to do

 

sudo iwconfig wlp58s0 txpower 15

 


The setting resets after rebooting, but you know what to do with it :). The network works well and the main thing is that now you can fully use the DELL U2715H external monitor.

Environment:

$ cat /etc/lsb-release 
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=20.2
DISTRIB_CODENAME=uma
DISTRIB_DESCRIPTION="Linux Mint 20.2 Uma"

$ uname -a
Linux max-laptop 5.13.0-21-generic #21~20.04.1-Ubuntu SMP Tue Oct 26 15:49:20 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

 

Top Contributor
Latest Solutions