Linux Developer Systems

2 Bronze

Dell XPS 13 9350 + Linux + Thunderbolt 3/USB-C

Hi all. I've been following these forums for a few weeks hoping to find a solid solution to my problem. Through my searching and browsing, it seems like there are numerous people mentioning the same or similar issue, but so far I can't seem to find any concrete solutions or knowledge from the community or from Dell. I'm hoping this post is more on-topic and provides more detail for the issue so we can better diagnose it and find a solution.

First though, the issue. I'm running the 2016 Dell XPS 13 9350 with an external Dell 4K monitor (P2415Q) using the USB-C/Thunderbolt 3 output with an adapter to mDP. I'm running Ubuntu 16.04 with 1.4.4 BIOS, and 4.7 mainline kernel. All drivers were updated as of two weeks ago prior to wiping Windows and installing Linux.

The external is recognized (i.e., it shows up in both xrandr and in Display settings) but the picture never remains. It will appear briefly, maybe for a few seconds or so, but then the screen goes black. I'll add that the external doesn't turn off (or go to sleep), but it doesn't display anything and is still shown in settings.

I've read that this could be related to ACPI power modes, namely RC6 with Skylake processors. I've tried appending a line to my kernel to disable RC6 entirely, but that doesn't seem to work. Along these lines, I've also read that this does fix some instances and this patch will be included in the 4.8 mainline kernel update (it's in RC2 right now, so soon?).

Admittedly the adapter I'm using is a $20 "cheapo" from Amazon, though the vendor does say it supports 4K at 60Hz (but I guess vendors can say whatever they want). I've been hearing positive things about Google's adapter, but don't want to shell out the $40 until I've narrowed the problem to the adapter. From the numerous other posts from folks using various adapters all whom are experiencing the same issues, I'm led to believe the adapter isn't the culprit.

I've also read that there could be some conflict with the wireless adapter, and that reducing its power stabilizes things. Unfortunately, reducing the power of my wireless adapter does not fix the issue, and even if it did, it is a suboptimal solution as it slows my connection considerably.

Some questions I'm hoping to get answers for are:

* is this a known issue and are my experiences on par with others, or are things slightly different?
* does Dell know about this issue, and are they working on a solution? I'm totally OK waiting for a solution, it'd just be nice to know one was being actively worked on
* is there a problem with the hardware? Is this Dells problem and I should return my device?
* is there some hidden driver update out there that fixes this issue (that's for Linux, not Windows)?
* has anyone found a temporary solution that does work?

I would like to scope this conversation to linux operating systems using external displays via the USB-C/Thunderbolt 3 connector, to hopefully keep it on-topic.

Thank you all in advance. I hope this thread proves useful to many.

Replies (37)
3 Silver

I'm glad to hear that. I have a USB3.0 drive that runs w10 and when I run w10 from the drive, I don't have the issue with monitors and such and TB15 runs fine. To me that points out software of some sort. But if a simple switch of a $20 part stabilizes things in the short term, I'm all for it. I turned off my wifi via bios and tried to do a HDMI via the DA200 but could not get any output under 4.8rc4.
2 Bronze

I did another test last night, this time keeping networking enabled, but just disconnecting from my local wifi. The result was success with an external monitor with flickering only happening once every 5 or so minutes. It's worth noting that when networking was disabled entirely, there was no flickering.

I suppose one could reduce the power of the wireless card, but if you're like me and further away from the router with only a mediocre signal at best, the wireless becomes unusable. The Intel card folks recommend as a replacement sounds like it's got a much stronger signal anyway.

I've ordered a replacement card which should arrive tomorrow. I'll report back over the weekend as to my findings. Fingers crossed.

3 Silver

I saw that the next version of the XPS 13 will have Killer wireless. Does anyone know which model works best with the XPS 13 9350? 

How'd the intel replacement work?

2 Bronze

Swapping the Intel wireless card didn't work. When I thought I had it working, a few minutes in it began flickering again, until the point the external is unusable. This is absolutely ridiculous and I can't believe Dell would ship a product that was faulty.

Unfortunately I'm beyond the 30 days for returns so I need to sell it second-hand, but I am going to give up and sell it. I work from home and need to be able to utilize the larger external to do said work; I can't work efficiently on a 13" screen. I knew this going in, but made the purchase dependent upon the external.

Folks I've worked with have had success with the Lenovo X1 Carbon, and it has a DisplayPort out, rather than this ridiculous Thunderbolt 3 that has zero support.

For the record, and for future reference, here's all the things I've tried:

  • shipped with 4.0.36 kernel; I tried 4.4, 4.6, 4.7 and even 4.8 RCs which had promising reviews
  • tried dialing back the power of the wireless card, did not work; only disabling it entirely seemed to reduce the flickering to once every minute, but not a robust solution for work which relies on the internet
  • created an xorg.conf.d configuration for 20-intel.conf which sets a few things; no-go
  • tried lowering the resolution of the external; this worked better, but not solid; plus i paid for a 4K monitor and I expect to be able to use it at its fullest resolution
  • tried various adapters and cables, notable All Smart Life TB3-to-mini DisplayPort adapter and the Google TB3 to DisplayPort cable; neither worked - rather both produced the same results
  • ensured my external (Dell's own P2415Q) supports DP1.2, which it does
  • ensured the external wasn't running in MST mode and that it was the primary (and only) display
  • installed the latest Intel drivers from 01.org using the update tool for 16.04 LTS
  • disabled those drivers in lieu of the default drivers per a recommendation elsewhere

None of this worked. I am extremely frustrated and the amount of money I've sunk could've gotten me a middle-of-the-road Lenovo X1 Carbon.

I'm going to hold off for a few days before ordering the Lenovo, if anyone has anything that helps that can change my mind, please post it here. You too, Dell, if you even pay attention.

Oh, and dealing with Dell's customer service is pointless because the language barrier prevents them from really understanding what the problem is.

3 Silver

That's too bad.  Just as a reference point prior to the dell xps 13 I had a Mbp 8,11 which had a Broadcom chip and Intel graphics.  I had the same issues with external monitors flickering.  There are more improvements needed in the tb15 I think but it's my belief that the kernel drivers need to mature (quickly) to solve the external monitor problems.

2 Bronze

Ah, that irrational hope that the TB15 will work correctly one day.

Keep it up! :)

2 Bronze

I am also having problems with DA200 adaptor, Arch Linux here with kernel 4.7.2-1-ARCH.
Dell Pro Support has been not helpful at all, they are just clueless, at least the people I have talked with from their support in Spain. Even more so, they just keep saying they "just cannot do anything".
In my case USB, VGA and Ethernet ports from the DA200 adaptor work just fine. However, HDMI output (the reason I actually bought this adaptor, actually) detects the external display and its supported resolutions (simple xrandr call to find out). However, when trying to send display signal, it won't get to the other end.
Reading through the forums I thought upgrading the Thunderbolt firmware [1] could fix the issue, but this update is an exe file that can only be run on a modern Windows environment (DOS will not suffice [2]).
I have tried to install Windows on another partition for a while now. Nothing works. The Windows installation does not recognize the hard drive (no matter the SATA Operation, None, AHCI or RAID), Boot mode Legacy or UEFI. No way for the Windows installation to detect the hard drive, and I only want to update the firmware to check if that fixes the issue. Browsing Drivers and loading them on the installation itself does not fix anything, the hard drive still cannot be detected. I even tried to launch a Windows live-cd environment like Gandalf, I could run the Thunderbolt update application, but at 45% of the process or so it raised an error "No thunderbolt detected on this computer", or something like that.
When I contacted the Dell Pro Support I asked if they could provide an ISO of the Windows for the 9350 Windows version (to install it without having to fight with Windows installation) they just told me I had to pay for it because a Windows licence wasn't on the original order.
I think trying to update the Thunderbolt firmware is worth a shot... If anyone is interested or can try that too.
Regards.
[1] <ADMIN NOTE: Broken link has been removed from this post by Dell>
[2] wiki.archlinux.org/.../Dell_XPS_13_(2016)
3 Silver

The DA200 was working much better under 4.6 or 4.7 but I don't know what comes and goes in the kernel to make things work better or worse. I think 4.8 is worse for i915 drivers, hot plugging and external displays in general.

I created a USB3.0 thumb drive W10 install so I could install patches and such as my original machine was a W10 system until I completely wiped it to install fedora. That may be easier than fiddling with partitions. I don't think upgrading the firmware will solve your issues because the software side is still maturing.

In 4.8, hotplugging seems to be partly working with DA200 USB not working on a hotplug but ethernet seems Ok. HDMI picks up the monitor but no signal goes out.

With 4.8RC5, DA200 and TB15 do not work for me or crashes my system when interacting with external displays. I did order the Intel WiFi as the broadcom prevents suspend from working correctly (so I unload it before suspending) and seems to be weak on signal strength. I'm still having some i915 related crashes once in awhile and screen flickering on the laptop display occasionally. I'm hoping Intel does some more updates on i915 before 4.8 GA and it looks like no more kernel updates related to the dock prior to 4.8GA.

I need to solve these display, adapter and dock problems in the next few months or I need to change out my laptop. Everything works fine under W10 from my perspective.

2 Bronze

I also created a Windows usb flash drive and updated the firmware with it. Still DA200 HDMI won't work. So I guess is just as you say, something missing on the software side, not the firmware one.

If you wait "a few months" Dell won't accept a refund for your laptop. I called them exactly for this, and told me (given the Spanish laws) I could have done so in the first 15 days after the purchase or so (I found out the HDMI was fishy way after 15 days - 80 days more or less).

Since I paid through PayPal I started a dispute to talk with Dell about this issue (by phone they would just not think about the problem or try to help -- they just kept repeating that they could do nothing to fix it, and that I couldn't go anywhere or talk to anybody from Dell to fix the issue). They didn't reply yet on the PayPal dispute.

However, and despite my guts tell me that I should return the laptop I have to say that it's a great one, and I think I'll keep it (it mostly depends on how the PayPal dispute goes -- if they are complete ***holes I will return it), and let's see if the software fixes those problems in a short period of time (let's see if we can also help on the linux kernel bugzilla).

Regards.

3 Silver

I just switched to the intel wireless card and at the very least my TB15 dock immediately began working again. I got back my network, mouse (USB) and monitors. I'm fedora 24 with 4.8rc5. Suspend now works without having to move the brcmfmac driver (and when I am not attached to the dock). It's not clear that the wireless card is better signal wise.

I'll see if I get flickering but at the very least the monitors actually showed content vs remaining black.

It was real hard switching the cards because the metal part of the old wireless card broke off inside the wire...best to proceed slowly with a steady hand. It took me an extra 30 min to dig out the broken metal ring inside the wire but a small pin worked.

I'll keep testing it out and report back. There appears to still be sensitivity to the order that I plug things in.

Top Contributor
Latest Solutions