Linux Developer Systems

2 Bronze

Dell XPS 13 9350 + Linux + Thunderbolt 3/USB-C

Hi all. I've been following these forums for a few weeks hoping to find a solid solution to my problem. Through my searching and browsing, it seems like there are numerous people mentioning the same or similar issue, but so far I can't seem to find any concrete solutions or knowledge from the community or from Dell. I'm hoping this post is more on-topic and provides more detail for the issue so we can better diagnose it and find a solution.

First though, the issue. I'm running the 2016 Dell XPS 13 9350 with an external Dell 4K monitor (P2415Q) using the USB-C/Thunderbolt 3 output with an adapter to mDP. I'm running Ubuntu 16.04 with 1.4.4 BIOS, and 4.7 mainline kernel. All drivers were updated as of two weeks ago prior to wiping Windows and installing Linux.

The external is recognized (i.e., it shows up in both xrandr and in Display settings) but the picture never remains. It will appear briefly, maybe for a few seconds or so, but then the screen goes black. I'll add that the external doesn't turn off (or go to sleep), but it doesn't display anything and is still shown in settings.

I've read that this could be related to ACPI power modes, namely RC6 with Skylake processors. I've tried appending a line to my kernel to disable RC6 entirely, but that doesn't seem to work. Along these lines, I've also read that this does fix some instances and this patch will be included in the 4.8 mainline kernel update (it's in RC2 right now, so soon?).

Admittedly the adapter I'm using is a $20 "cheapo" from Amazon, though the vendor does say it supports 4K at 60Hz (but I guess vendors can say whatever they want). I've been hearing positive things about Google's adapter, but don't want to shell out the $40 until I've narrowed the problem to the adapter. From the numerous other posts from folks using various adapters all whom are experiencing the same issues, I'm led to believe the adapter isn't the culprit.

I've also read that there could be some conflict with the wireless adapter, and that reducing its power stabilizes things. Unfortunately, reducing the power of my wireless adapter does not fix the issue, and even if it did, it is a suboptimal solution as it slows my connection considerably.

Some questions I'm hoping to get answers for are:

* is this a known issue and are my experiences on par with others, or are things slightly different?
* does Dell know about this issue, and are they working on a solution? I'm totally OK waiting for a solution, it'd just be nice to know one was being actively worked on
* is there a problem with the hardware? Is this Dells problem and I should return my device?
* is there some hidden driver update out there that fixes this issue (that's for Linux, not Windows)?
* has anyone found a temporary solution that does work?

I would like to scope this conversation to linux operating systems using external displays via the USB-C/Thunderbolt 3 connector, to hopefully keep it on-topic.

Thank you all in advance. I hope this thread proves useful to many.

Replies (37)
2 Bronze

I've got things working almost perfectly.

I'm using the Intel 7265 card (removed Dells/Broadcom piece of ***). However, my router automatically shifts between 20MHz and 40MHz modes when on the 2.4GHz network. It's the switches that caused the flicker, so I forced my router to only work on 20MHz channel when using the 2.4GHz network in my house. This was the solution.

Not sure why Dell ships hardware with known defects. A little irresponsible if you ask me, but I digress.

I did have to update to kernel 4.8rc6 to get 4k support on my external though. It might've been accidentally removed from 4.7 and earlier 4.8rc versions.

Good luck!

3 Silver

I am not actually convinced that it is a hardware problem. I had many, many problems with the Broadcom chip in my MacBook Pro and the Linux drivers that it used. Based on those experiences it really does feel like there is a significant kernel module problem. Given that it works fine for me under windows 10, I tend to believe that there is a problem in the combination of hardware and Intel kernel module. And given that the Intel module seem to have significant problems with both video and wireless, I tend to believe the statement that it is a combination of the hardware, firmware and kernel modules that is causing us the problems.
3 Silver

Of course in my last statement I meant the Intel video driver and the Broadcom  wireless kernel driver.

3 Silver

I've had good luck with the new intel wireless card and 4.8rc6 on the xps 13 9350. TB15 USB, ethernet and 2 video outs work (HDMI and mDP). There is sensitivity to dock plug-in sequence. Audio does not seem to work through the dock although the device appears to be detected. I've not checked network performance. I have power management on with the i915 module. I do not have 4K monitors.

I encounter the dreaded CPU pipe X FIFO underrun error occasionally, usually when moving the mouse rapidly between screens) and then there is screen blank on the screen that generates it (I assume associated with the CPU pipe associated with that display) but I'm not getting any other random screen blank/flicker behavior I had before. I do get an occasional flicker on the laptop screen and they are often accompanied by a userif-0: sent link up event (and "link down"). Rapid movement of the mouse between screens does generate some screen flicker.

I am getting NOHZ: local_softirq_pending 08 messages in my journalctl -k -f log watching but that does not seem to cause usage problems.

Suspend while attached to the dock does not seem to work consistently.

I've not tried my DA200 yet but I'll do that next week when I travel.

2 Bronze

I upgraded to Kernel 4.8 hoping something would change, but my DA200 simply doesn't work. When using HDMI it still recognizes the second screen but no signal is sent. VGA won't work at all (not even recognize the second screen). Anybody from Dell that may have suggestions? Pro support has proven to be useless in this situation.

2 Bronze

I determined the issue not to be with the kernel, but with the 2.4GHz wifi channel. Two things helped me:

First, I found the problem linked to automatically switching 20/40MHz wireless channels when on 2.4GHz networks. I disabled the automatic switching which stabilized the wireless card.

Second, I set my laptop to connect only to my 5GHz network eliminating the hunt for channels altogether. This seems to be 99% stable for me.

It seems that the proximity or lack of shielding between the wireless card and the display hardware causes the issue, be it flickering of external monitors, or non-working externals altogether.

The fact that this problem doesn't exist in Windows means that it's definitely a software issue, but I also blame Dell for not testing this properly before shipping the product.

2 Bronze

Just to add my two cents, the problems mentioned here do in fact occur within Windows with both USB-C and Thunderbolt 3 devices, and I wrote about them on my employers blog (we make USB-C and Thunderbolt 3 devices).

The Dell forum is not letting me include a link to the post (I think I'm too new), but if you Google "INVESTIGATING USB-C PROBLEMS ON SOME DELL XPS AND PRECISION LAPTOPS' you should find the page on our website. While I believe it to be obvious, in the interest of full disclosure I work for Plugable Technologies.

2 Bronze

I wanted to chime in and add that while I have the same problem with the external display popping in and out, I can mitigate it to some extent by tilting the laptop lid down to 85 degrees or so. It's less than ideal, but it stabilizes the connection and everything appears to work just fine.


If I tilt the laptop lid open past 90 degrees, the connection to the external display gets squirrely again.

2 Bronze

I still haven't been able to solve or work around this (which means that I have a useless DA200 sitting in my desk). I think that the time is well beyond when Dell should have said something about this. @Dell: any suggestions/solutions? 

2 Bronze

To follow up with my post, I replaced the Broadcom wireless chip with the Intel 7265NGW chip and I've not had any problems with the display flickering since.

Top Contributor
Latest Solutions