bobmcch
Bronze

Keyboard backlight doesn't remember setting

Hello,

I've not done full testing or checked whether this occurred in earlier versions of Ubuntu (I've upgraded to Ubuntu 15.10 so this *could* be a regression, or I may have never spotted this before), but my first task is to see if anyone else gets this issue.

When I set my keyboard backlight to be off (with Fn+F7), if my screen is put to sleep and I then wake it up again, the keyboard backlight comes on with the screen.

This is very easy to reproduce for me. With the laptop powered on and logged in to Ubuntu 15.10 (on battery or AC, irrelevant), I press Ctrl-Alt-L to lock, don't touch touchpad or keyboard until screen dims and turns off (takes under 20 seconds), and then when I touch the touchpad or keyboard then both the screen and the keyboard light up.

If people wouldn't mind checking and reporting back (with details about distro/version being run) then I'll know whether it might be raised as a Linux bug or a Dell firmware bug. It would be much appreciated. (Just so you don't think I'm being completely lazy, if there are no replies in a few days, I'll probably go back to factory image to test myself; I'm just really short on time right now and wanted to report while I remember.)

Cheers,
Bob

0 Kudos
2 Replies
eb5
Copper

RE: Keyboard backlight doesn't remember setting

On my M3800, the keyboard backlight came on at boot and stayed on forever through Ubuntu 15.04.  That is what I require due to vision issues.

After upgrading to 15.10, the keyboard backlight no longer comes on at boot.  Worse, after it times out and turns off, it doesn't switch back on after a keystroke, I need to manually switch it on with FN+F10.

Likewise after suspend/resume.

0 Kudos
bobmcch
Bronze

RE: Keyboard backlight doesn't remember setting

Looks like when I made this post I didn't search properly for existing threads. Someone else has raised this in the following post:

http://en.community.dell.com/techcenter/os-applications/f/4613/t/19658570

Also, same person has raised a question here:

https://askubuntu.com/questions/180712/how-to-enable-laptop-mode

I've not had time to try with earlier versions, but the other user's report confirms in my mind that it's a regression in Ubuntu 15.10. I'll move myself over to the other thread to discuss there.

Cheers,
Bob

0 Kudos