CuriousTommy
1 Copper

My Dell Precision 5510 Laptop Does Not Go To Sleep Sometimes

Jump to solution

Hello Everyone,

I am having this problem with my Dell Precision 5510 laptop where sometimes the machine would not go to sleep if I close my machine's lid. I am actually running Arch Linux instead of the official Dell Ubuntu distro.

I know that sleeping normally does work when closing the lid since most of the time, my machine would feel cold when I take it out of my backpack. But this is starting to become more of a problem recently where my machine would be burning hot when I take it out of my backpack. I am worried that my laptop will not last for long if this keeps happening...

I am not sure if this is an improper configuration of Arch Linux or a hardware issue. Has anyone else experienced these problems?

Thomas A.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
kstoilov
1 Copper

RE: My Dell Precision 5510 Laptop Does Not Go To Sleep Sometimes

Jump to solution

This is probably caused by the following ACPI error, which is due to Dell's broken BIOS. It is a known issue it seems:

[200729.138383] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.CHRG] Namespace lookup failure, AE_NOT_FOUND (20160422/psargs-359)

[200729.138393] ACPI Error: Method parse/execution failed [\PNOT] (Node ffff8ad82d0e05c8), AE_NOT_FOUND (20160422/psparse-542)

[200729.138404] ACPI Error: Method parse/execution failed [\_SB.AC._PSR] (Node ffff8ad82d0f3b68), AE_NOT_FOUND (20160422/psparse-542)

[200729.138748] ACPI Exception: AE_NOT_FOUND, Error reading AC Adapter state (20160422/ac-128)

There is another thread en.community.dell.com/.../20006889 with more discussion around the topic of ACPI errors

2 Replies
Highlighted
kstoilov
1 Copper

RE: My Dell Precision 5510 Laptop Does Not Go To Sleep Sometimes

Jump to solution

This is probably caused by the following ACPI error, which is due to Dell's broken BIOS. It is a known issue it seems:

[200729.138383] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.CHRG] Namespace lookup failure, AE_NOT_FOUND (20160422/psargs-359)

[200729.138393] ACPI Error: Method parse/execution failed [\PNOT] (Node ffff8ad82d0e05c8), AE_NOT_FOUND (20160422/psparse-542)

[200729.138404] ACPI Error: Method parse/execution failed [\_SB.AC._PSR] (Node ffff8ad82d0f3b68), AE_NOT_FOUND (20160422/psparse-542)

[200729.138748] ACPI Exception: AE_NOT_FOUND, Error reading AC Adapter state (20160422/ac-128)

There is another thread en.community.dell.com/.../20006889 with more discussion around the topic of ACPI errors

Queuecumber
1 Copper

RE: My Dell Precision 5510 Laptop Does Not Go To Sleep Somet

Jump to solution

Do you know what the result of the discussion was or if there is any workaround? That topic is locked by Dell it seems.

0 Kudos