Linux Developer Systems

Last reply by 10-15-2013 Unsolved
Start a Discussion
2 Bronze
2 Bronze
64830

My XPS developer edition L322X keeps freezing 2-3/week

Hi everybody.

I have an issue with this laptop, I have randomly freezes (2-3/week) since I bought it (begin of April) and even after doing the update or trying the kernel 3.5.0 .

When freezing, the system totally freeze, no possibility to access to others tty or to do anything else than pushing the power button. 

There is already a bug opened on launchpad https://bugs.launchpad.net/dell-sputnik/+bug/1167624, but that could be also a hardware problem.

Any idea how to solve it ?

Thanks,

Matthieu

Replies (14)
2 Bronze
2 Bronze
710

I experience this as well. I've read that updating the BIOS fixes it, but I haven't done it yet myself. (I'm still on version A2.)

3 Silver
710

If your system is totally locked up like that, there's one recovery thing to try:

Hold down ALT+PrtScr and then tap each of these keys individually a few seconds apart:

R S E I N U B

You can look up what all this does (each letter progressively starts shutting things down) but the short answer is that it flushes your buffers to disk, attempts to kill processes cleanly, etc., and the 'B' at the end tries a reboot.

There's a mnemonic to remember: Raising Skinny Elephants Is Never Utterly Boring

2 Bronze
2 Bronze
710

Thanks for the reply, I have already the last BIOS version available for this one, A08. www.dell.com/.../xps-13-l321x-mlk

(also perhaps you have not the L322X version but the L321X )

2 Bronze
2 Bronze
710

@iandouglas736  thanks a lot, I will try this the next time.

2 Bronze
2 Bronze
711

I tried ALT+PrtScr and R S E I N U B but nothing happenned..

2 Bronze
2 Bronze
711

Try with an externally attached USB keyboard. I've never gotten REISUB to work with the onboard KB, using either Fn+PrtScrn or Fn+SysRq

2 Bronze
2 Bronze
711

Even with an externally attached USB keyboard,nothing happen.

2 Bronze
2 Bronze
711

Any news on this? How do we hit the SYSRQ on a XPS13?

2 Bronze
2 Bronze
711

A kernel update (package linux-image-generic-lts-quantal) fixed this for me, as described at bugs.launchpad.net/.../1167624

Latest Solutions
Top Contributor