dthiery
1 Nickel

Problem with bluetooth mouse

I just got a bluetooth mouse (Microsoft Designer) and it works for a few minutes but then it'll stop and the following is in dmesg:

Bluetooth: hci0: Setting Intel event mask failed (-16)

Any idea how to fix that?

4 Replies
Not applicable

RE: Problem with bluetooth mouse

I've also got bluetooth issues with both the mouse as well as iphone bluetooth hotspot. Happens under all kernel versions I tried.


For a practical answer: you can give your bluetooth controller a kick using: sudo hciconfig hci0 reset .


There seem to me to be driver issues, even in the developer edition.

0 Kudos
Not applicable

RE: Problem with bluetooth mouse

Thing have only been getting worse in the latest kernels.

4.6.3 I use now, but even the hcitool trick doesn't help any longer.

Bluetooth on XPS skylake seems quite broken?

0 Kudos
newman_as
1 Copper

RE: Problem with bluetooth mouse

I have the same problem. The mouse stops working after a while and if I turn off and on the bluetooth indicator everything start working again.  Then the mouse will stop moving again and so on.

Since it is able to work it seems a solvable issue to me, but I have no idea how to fix it

0 Kudos

RE: Problem with bluetooth mouse

Could people with this issue please add to https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1651433 ? Especially if you're running our OEM image, specify the Ubuntu version.

--
Project Sputnik development lead
Software Principal Engineer
Linux OS Architecture
Dell | Client Product Group

0 Kudos