Highlighted
Roland36
1 Copper

Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

Hi,

I am using a recently purchased XPS 13 with the 14.04 version of Ubuntu that was installed at the factory. I have accepted all of the updates. So I'm at:

4.4.0-38-generic #57~14.04.1-Ubuntu SMP Tue Sep 6 17:20:43 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I'm having trouble with the screen flashing and jumping when using Chrome. The problem is worse on sites like yahoo.com. I suspect it is related to Flash-based ads prevalent on such sites, but I don't know.

The display section of lshw is below. I don't know exactly what info one might need to diagnose the problems so let me know what I can do to fill in the details.

FWIW, here is a cell phone video of the flashing: https://goo.gl/photos/oUqScjipjRiijCXi7

Also, for FWIW I installed the DIsplayLink drivers in an attempt to use an external monitor. After not being satisfied with the external monitor situation I followed the uninstall procedure for the DisplayLink drivers, but don't know if there are packages leftover from that that might be affecting the display.

Thanks,

Roland

*-display
description: VGA compatible controller
product: Sky Lake Integrated Graphics
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 0a
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
rom
configuration: driver=i915_bpo latency=0
resources: irq:281 memory:db000000-dbffffff memory:90000000-9ffffff
f ioport:f000(size=64)

0 Kudos
11 Replies
bobxps13
1 Nickel

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

0 Kudos
Roland36
1 Copper

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

Thanks.

Even though it's not "a Dell problem" per se, this seems like the best forum to get answers for how folks are dealing with this issue.

So far the choice seems to be live with the flashing, don't run the browser full screen or boot to an older kernel.

Anybody have any other suggestions?

Roland

0 Kudos
Roland36
1 Copper

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

And for what it's worth, booting to 

3.19.0-69-generic #77~14.04.1-Ubuntu SMP Tue Aug 30 01:29:21 UTC 201
6 x86_64 x86_64 x86_64 GNU/Linux

make the less severe, but does not eliminate the flashing.

Roland

0 Kudos
bobxps13
1 Nickel

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

this flickering gets really annoying since it effects every chromium based software. (eg visual studio code or opera and so on) anyone tried this here ?

https://bugs.chromium.org/p/chromium/issues/detail?id=606152#c73

will this work on 14.04 and the xps 13 (skylake)? what about external monitor and KMS.
by the way which driver is used on an dell stock 14.04? cant figure this out.

0 Kudos
bobxps13
1 Nickel

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

since the last two chrome updates or so the workaround with the additional commandline options

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

works for me with latest opera and chrome. doesn't work in chromium or vs code
i am on ubuntu 14.04 with kernel 4.4-47 on my xps13 9350

0 Kudos
Lugdum
1 Copper

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

I had the same issue on my Dell XPS 13 9360 Ubuntu 16.04. It was only happening using Google Chrome. I fixed it by accessing following URL in chrome: chrome://flags and changing GPU Rasterization to "Force-enabled for all layers". I saw this trick in another forum.

Hoping it will help.

hamkaas
1 Nickel

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

Thanks @Lugdum for sharing. Your fix works great. This bug is tracked for Chromium at:

Chromium bug tracker

Inside the bug report are also links to Ubuntu and Xorg bugtrackers.

0 Kudos
Roland36
1 Copper

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

For me in the end, the change reduced the flashing, but did not eliminate the problem entirely when the browser was open to full screen.

Thanks for the information and the links to the bug report.

Roland

0 Kudos
bobxps13
1 Nickel

RE: Screen flashes using Chrome, Dell XPS 13, Ubuntu 14.04

have you tried the 2 additional start parameters i mentioned ? that's the only thing which works for me.
the problem with it is, you have to add it again after every browser update to the desktop config file. 

0 Kudos