Linux Developer Systems

Last reply by 09-07-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Upgrade to Ubuntu 22.04 on a DELL Latitude E6430

Hi; i have Ubuntu 20.04 and it runs smoothly on a DELL E6430. However, when I try to upgrade to 22.04 via accepting the offer in Sotware Updates, by pressing "Upgrade" , then nothing happens. Then when I do it in terminal, and do:


sudo apt-update

(nothing new to update)


sudo-apt upgrade

a small upgrade is made of 2000 kb


then to finally upgrade to 22.04 I do:

sudo apt full-upgrade

and I get the disappointing reply:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



Hence, nothing is available on terminal.


Replies (3)

Hello, I see you are looking for technical assistance. If you need our help, you can private message with us and we will be happy to assist you.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

2 Bronze
2 Bronze

I don't know about your specific problem but on my machine when tried to upgrade to 22.04 it wasn't working because of the dell-linux-assistant that could no be upgraded or something like that.

You could see if that is also a problem on your machine by running something like this:


sudo apt list --upgradable -a


Because that application did not work on 20.04 on my machine either I just removed it. But I saw that there is also a ask-ubuntu question about it: might be worth looking into if that's indeed the cause of the problem.


Hi Johannes, I ended up installing a fresh install. It worked out well, so I suppose that is the best thing for this case .



Latest Solutions
Top Contributor