Visyu
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

I have the same problem with my new 9370 device. It also happens during work without suspend. I need to reboot the machine an disable/enable bluetooth in BIOS. Please fix this asap or give us a good workaround.

0 Kudos
jamtur01
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

Is everyone using TLP? 

systemctl status tlp
tlp.service - TLP system startup/shutdown
   Loaded: loaded (/lib/systemd/system/tlp.service; enabled; vendor preset: enab
   Active: active (exited) since Wed 2018-04-04 22:39:31 EDT; 11h ago
     Docs: http://linrunner.de/tlp
  Process: 19359 ExecStop=/usr/sbin/tlp init stop (code=exited, status=0/SUCCESS
  Process: 19444 ExecStart=/usr/sbin/tlp init start (code=exited, status=0/SUCCE
Main PID: 19444 (code=exited, status=0/SUCCESS)

Apr 04 22:39:31 james-XPS-13-9370 systemd[1]: Starting TLP system startup/shutdo
Apr 04 22:39:31 james-XPS-13-9370 tlp[19444]: Applying power save settings...don
Apr 04 22:39:31 james-XPS-13-9370 tlp[19444]: Setting battery charge thresholds.
Apr 04 22:39:31 james-XPS-13-9370 systemd[1]: Started TLP system startup/shutdo

I note that TLP seems to be auto-suspending BTUSB.

I have excluded Bluetooth from TLP's auto-suspend by editing `/etc/default/tlp`.

 Bluetooth devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.
USB_BLACKLIST_BTUSB=1 # changed to one  

And set this option to `1`. It seems to have resolved the issue from what I can see. I'll update if it doesn't.

0 Kudos
jamtur01
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

Nope. It's not TLP. Same problem appeared. I am a loss I am afraid at this point.

0 Kudos
chrstl
1 Copper

Re: XPS 13 9370 no bluetooth after suspend

I do have the same behaviour also sometimes with the wifi :-(

0 Kudos
Visyu
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

0 Kudos
chrizzlier
1 Copper

Re: XPS 13 9370 no bluetooth after suspend

Is there a public bug tracker? I would like to say "me too" instead of filling out a complete bug report.

0 Kudos
chrizzlier
1 Copper

Re: XPS 13 9370 no bluetooth after suspend

A workaround which works for me is shutdown and turn off the laptop, wait a few seconds, and turn it on again.

Directly rebooting does not work when I have this problem.

 

gniewomir
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

I'am also affected by this bug and yes, a bug tracker would be nice. Smiley Happy

0 Kudos

Re: XPS 13 9370 no bluetooth after suspend

All,

I apologize for the frustration.   

If you are in North America and have contacted support around the bluetooth issue, please send me a direct msg with either your case number, service request number or service tag.  We can then look into the cases from our side and see what's up and where we can help.

thanks!

Barton George

Visyu
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

I created a bug report here: https://bugs.launchpad.net/dell-sputnik/+bug/1766825

If someone has additional info, maybe it would help to put it there. Also a mention, if it affects more people would be nice.

0 Kudos